POJ 2954 Triangle (皮克定理)

57 篇文章 0 订阅
Triangle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5646 Accepted: 2433

Description

lattice point is an ordered pair (xy) where x and y are both integers. Given the coordinates of the vertices of a triangle (which happen to be lattice points), you are to count the number of lattice points which lie completely inside of the triangle (points on the edges or vertices of the triangle do not count).

Input

The input test file will contain multiple test cases. Each input test case consists of six integers x1y1x2y2x3, and y3, where (x1y1), (x2y2), and (x3y3) are the coordinates of vertices of the triangle. All triangles in the input will be non-degenerate (will have positive area), and −15000 ≤ x1y1x2y2x3y3 ≤ 15000. The end-of-file is marked by a test case with x1 =  y1 = x2 = y2 = x3 = y3 = 0 and should not be processed.

Output

For each input case, the program should print the number of internal lattice points on a single line.

Sample Input

0 0 1 0 0 1
0 0 5 0 0 5
0 0 0 0 0 0

Sample Output

0
6

Source


大体题意:

给你三角形的三个顶点(都是int整数),求三角形内部整数点的个数(不包括边界)

思路:

用到了皮克定理:S = a + b / 2 -1;

S为三角形面积,a为内部点的个数,b为边界点的个数。

1.面积用叉积求出

2.边界点:

比如说 一条线段两个端点(x1,y1)和(x2,y2),那么这个线段的整数点个数为gcd(x2-x1,y2-y1);  其中gcd()为最大公约数!

满足等式求解即可!

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;
const int co = 15000;
int gcd(int a,int b){
	return b == 0 ? a : gcd(b,a%b);
}
int main(){
	int x1,y1,x2,y2,x3,y3;
	while(scanf("%d%d%d%d%d%d",&x1,&y1,&x2,&y2,&x3,&y3) == 6 && (x1 || y1 || x2 || y2 ||x3 || y3)){
		x1+=co;y1+=co;
		x2+=co;y2+=co;
		x3+=co;y3+=co;
		double s = fabs((x2-x1) * (y3-y1) * 1.0 - (y2-y1) * (x3-x1) * 1.0)/2.0;
		int on = gcd(abs(x2-x1),abs(y2-y1)) + gcd(abs(x3-x2),abs(y3-y2)) + gcd(abs(x3-x1),abs(y3-y1));
		double ans = s - on*1.0/2+1;
		printf("%.0f\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值