HDU 4355 Party All the Time (三分)

78 篇文章 0 订阅
3 篇文章 0 订阅

Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4783    Accepted Submission(s): 1508


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers.
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

Sample Input
  
  
1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

Sample Output
  
  
Case #1: 832 大体题意: 给你n个实数点,并且告诉你每个点有一个实数权值! 让你在数轴上找一个点使得不高兴值最小。 计算方法在题目中找吧! 思路 三分, 通过这个题目学习了下三分。 看到网上博客!都是用了 先取mid = (l+r)/2; midmid = (mid+r)/2; 看看mid 和midmid哪个更优从而来更新r和l。 循环条件是r - l > eps; 循环终止后要在计算一遍l,r来进一步取最优! 输出最小ans即可! 教训: 数学函数中的pow 函数是很慢的!尽量不要用! 超时了n次!
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int maxn = 50000 + 10;
const double eps = 1e-8;
double a[maxn],w[maxn];
int n;
double go(double k){
    double sum = 0.0;
    for (int i = 0; i < n; ++i){
        double tmp = a[i]-k;
        if (tmp < 0)tmp = -tmp;
        sum += tmp*tmp*tmp*w[i];
    }
    return sum;
}
int main(){
    int T;
    int cnt=0;
    scanf("%d",&T);
    while(T--){

        scanf("%d",&n);
        for (int i = 0; i < n; ++i){
            scanf("%lf%lf",&a[i],&w[i]);
        }
        double r = a[n-1],l = a[0];
        while(r-l > eps){
            double mid = (r+l)/2.0;
            double mm = (mid+r)/2.0;
            if (go(mid) < go(mm))r = mm;
            else l = mid;
        }
        double ans1 = go(l);
        double ans2 = go(r);
        double ans;
        ans = min(ans1,ans2);
        printf("Case #%d: %.0lf\n",++cnt,ans);

    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值