HDU 2680 Choose the best route(Dijkstra算法)

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12523    Accepted Submission(s): 4072


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 
大体题意:
KiKi要去拜访他的朋友,问最短路是多少。
其中s 是他朋友的编号。
与他自己相连的车站有很多。
思路:
直接设KiKi的编号为0,把相连的车站连起来,权值设为0,一遍Dijkstra算法即可!
注意 他的目标是S而不是n  (= =!)
到达不了输出-1.

注意  该题目是有向图!
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1000 + 10;
const int INF = 1000000 + 10;
int g[maxn][maxn],d[maxn];
int n,m,s;
bool v[maxn];
void dijkstra(int s){
    memset(v,0,sizeof v);
    for (int i = 0; i <= n; ++i)d[i] = (i == s ? 0 : INF);
    for (int i = 0; i <= n; ++i){
        int x,m = INF;
        for (int y = 0; y <= n; ++y) if (!v[y] && d[y] <= m)m = d[x=y];
        v[x] = 1;
        for (int y = 0; y <= n; ++y) d[y]= min(d[y],d[x]+g[x][y]);
    }
}
int main(){
    while(scanf("%d%d%d",&n,&m,&s) == 3){
        for (int i = 0; i <= n; ++i)
            for (int j = 0; j <= n; ++j)
                g[i][j] = INF;
        for (int i = 0; i < m; ++i){
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            g[u][v] = min(g[u][v],w);
        }
        int k;
        scanf("%d",&k);
        for (int i = 0; i < k; ++i){
            int w;
            scanf("%d",&w);
            g[0][w] = 0;
        }
        dijkstra(0);
        printf("%d\n",d[s] == INF ? -1 : d[s]);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值