HDU 5442 Favorite Donut(最大表示法)

Favorite Donut

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2746    Accepted Submission(s): 667


Problem Description
Lulu has a sweet tooth. Her favorite food is ring donut. Everyday she buys a ring donut from the same bakery. A ring donut is consists of n parts. Every part has its own sugariness that can be expressed by a letter from a to z (from low to high), and a ring donut can be expressed by a string whose i-th character represents the sugariness of the ith part in clockwise order. Note that z is the sweetest, and two parts are equally sweet if they have the same sugariness.

Once Lulu eats a part of the donut, she must continue to eat its uneaten adjacent part until all parts are eaten. Therefore, she has to eat either clockwise or counter-clockwise after her first bite, and there are 2n ways to eat the ring donut of n parts. For example, Lulu has 6 ways to eat a ring donut abc : abc,bca,cab,acb,bac,cba . Lulu likes eating the sweetest part first, so she actually prefer the way of the greatest lexicographic order. If there are two or more lexicographic maxima, then she will prefer the way whose starting part has the minimum index in clockwise order. If two ways start at the same part, then she will prefer eating the donut in clockwise order. Please compute the way to eat the donut she likes most.
 

Input
First line contain one integer T,T20 , which means the number of test case.

For each test case, the first line contains one integer n,n20000 , which represents how many parts the ring donut has. The next line contains a string consisted of n lowercase alphabets representing the ring donut.
 

Output
You should print one line for each test case, consisted of two integers, which represents the starting point (from 1 to n ) and the direction ( 0 for clockwise and 1 for counterclockwise).
 

Sample Input
  
  
2 4 abab 4 aaab
 

Sample Output
  
  
2 0 4 0
 

Source
 

大体题意:
给你一个长度为n 的字符串,你有2n种方式构造这个字符串,就是从某一个位置开始逆时针或者顺时针走,求出字典序最大的方案并且求出位置,如果正反字典序相同,输出位置小的那个!
思路:
用最小表示法模板改造成最大表示法,顺时针很好说。
逆时针的话,虽然反转了字符串,但位置也反转了,所以有个小小的改动:
        if (k >= n){
            i = i + (n-1-i)/(j-i)*(j-i);
            break;
        }
详细见代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<iostream>
using namespace std;
int ans[2];
const int maxn = 20000 + 10;
string solve1(string s,int id){
    int i,j,k,l;
    int n = s.length();
    s+=s;
    for (i = 0, j = 1; j < n; ){
        for (k = 0; k < n && s[i + k] == s[j + k]; ++k);
        if (k >= n)break;

        if (s[i+k] > s[j+k])
            j += k+1;
        else {
            l = i + k;
            i = j;
            j = max(j,l) + 1;
        }
    }
    ans[id] = i;
    return s.substr(i,n);
}
string solve2(string s,int id){
    int i,j,k,l;
    int n = s.length();
    s += s;
    for (i = 0, j = 1; j < n; ){
        for (k = 0; k < n && s[i+k] == s[j+k]; ++k);\

        if (k >= n){
            i = i + (n-1-i)/(j-i)*(j-i);
            break;
        }
        if (s[i+k] > s[j+k]){
            j += k+1;
        }
        else{
            l = i + k;
            i = j;
            j = max(j,l)+1;
        }
    }
    ans[id] = i;
    return s.substr(i,n);

}
char s[maxn];
int main(){
    int T;
    scanf("%d",&T);

    while(T--){
        int n;
        scanf("%d",&n);
        scanf("%s",s);
        string s1 = solve1(s,0);
        reverse(s,s+n);
        string s2 = solve2(s,1);
        int ans1 = ans[0],ans2 = ans[1];
        if (s1 > s2){
            printf("%d %d\n",ans1+1,0);
        }
        else if (s1 < s2){
            printf("%d %d\n",n-ans2,1);
        }
        else{
            int pos1 = ans1 + 1;
            int pos2 = n-ans2;
            if (pos1 <= pos2)printf("%d %d\n",ans1+1,0);
            else printf("%d %d\n",n-ans2,1);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值