1004. 成绩排名 (20)

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
题目不难,但是代码却千差万别。
C的链表
#include<stdio.h>
#include<stdlib.h> 
#define LEN sizeof(struct Student)
struct Student{
	char name[11],num[11];
	int score;
	struct Student * next;
};
int main(){
	struct Student *  create(int n); 
    void printMaxMin(struct Student * stu);
    int n;
    scanf("%d",&n);
    printMaxMin(create(n));
	
	
}

struct Student *  create(int n){
  	struct Student *  create(int n);
	struct Student * head=NULL;
	struct Student * p1,*p2;
	p1=p2=(struct Student *)malloc(LEN);
	scanf("%s %s %d",&p1->name,&p1->num,&p1->score);	
	head=p1;
	n--;
	while(1){
	  p2->next=p1;
	  p2=p1;
	  if(n-->0){
	  	 p1=(struct Student *)malloc(LEN);
         scanf("%s %s %d",&p1->name,&p1->num,&p1->score);
	  }else{
	  	break;
	  } 
	}
	p1->next=NULL;
	return head;
}

void printMaxMin(struct Student * stu){
	int max,min;
	max=min=stu->score;
	struct Student * p,*maxP,*minP;
	p=maxP=minP=stu;
	while(p!=NULL){
		if(p->score>max){
			max=p->score;
			maxP=p;
		}else	if(p->score<min){
			min=p->score;
		    minP=p;
		}
		p=p->next;
	} 
	
	printf("%s %s\n",maxP->name,maxP->num);
	printf("%s %s\n",minP->name,minP->num);
}
C++中的sort
#include<iostream>
#include<algorithm>
#include<string>

using namespace std;

struct Student{
  string name,num;
  int score;
}a[105];
bool compare(Student a,Student b){
      return a.score>b.score;   //根据分数降序排列
}
int main(){
  	int n;
  	cin>>n;
  	for(int i=0;i<n;i++){
  		cin>>a[i].name>>a[i].num>>a[i].score;
 	}
 	sort(a,a+n,compare);
 	cout<<a[0].name<<" "<<a[0].num<<endl;
 	cout<<a[n-1].name<<" "<<a[n-1].num<<endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值