L2-005. 集合相似度


给定两个整数集合,它们的相似度定义为:N c/N t*100%。其中N c是两个集合都有的不相等整数的个数,N t是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

输入格式:

输入第一行给出一个正整数N(<=50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(<=104),是集合中元素的个数;然后跟M个[0, 109]区间内的整数。

之后一行给出一个正整数K(<=2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

输出格式:

对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

输入样例:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
输出样例:
50.00%
33.33%
 
最容易想到的就是借助桶算法来实现,然而数据比较大。所以这时候可以用C++STL中的set,因为set实现了去重。下面是set的定义:
 
 
Sets are containers that store unique elements following a specific order. In a set, the value of an element also identifies it (the value is itself the key, of type T), and each value must be unique. The value of the elements in a set cannot be modified once in the container (the elements are always const), but they can be inserted or removed from the container. Internally, the elements in a set are always sorted following a specific strict weak ordering criterion indicated by its internal comparison object (of type Compare). set containers are generally slower than unordered_set containers to access individual elements by their key, but they allow the direct iteration on subsets based on their order. Sets are typically implemented as binary search trees.
#include <iostream>
#include<set>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;

int main(int argc, char** argv) {
	int n,m[55],k;
	set <int> a[55];
	int b,c;
	int i,j,nc,nt;
	cin>>n;
	for(i=1;i<=n;i++){
		cin>>m[i];
		for(j=0;j<m[i];j++){
			int t;
			cin>>t;
			a[i].insert(t);
		}
	}
	cin>>k;
	for(i=0;i<k;i++){
		cin>>b>>c;
		nc=nt=0;
		int len1=a[b].size();
		int len2=a[c].size();
		set<int> t=a[b];
		set<int>::iterator it;
		for(it=a[c].begin();it!=a[c].end();it++){
			//t.insert(*it);
			if(a[b].find(*it)!=a[b].end()){
				nc++;
			}
		}
		//nt=t.size();
		//nc=len1+len2-nt;
		nt=len1+len2-nc;
		printf("%.2f\%\n",100.0*nc/nt);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值