HDU-P1061:Rightmost Digit[找规律]

HDU-P1061:Rightmost Digit[找规律]

题目

题目链接

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4
Sample Output
7
6
Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

思路

这个题目和C语言基础100题里的人见人爱A^B的意思几乎完全一样,但是解法照搬的话会超时,我也没有想到这个题的解法,所以在网上找了找思路,发现这个题目是一个找规律的题目:
先列出几个简单数据的看一看

数字答案
11
24
39
46
55
66
73
86
99

可以发现(当然不是我发现的)答案是当前数字的n次方模10得到的,其中n从1开始,每四个一循环。

代码

问题想明白之后答案就简单多了。

#include<iostream>
using namespace std;
int main()
{
    long long t;
    cin>>t;
    long long sum=1;
    while(t--)
    {
        long long n,m;
        sum=1;
        cin>>n;
        m=(n-1)%4;
        n=n%10;
        for(int i=0;i<=m;i++)
        {
            sum=sum*n;
        }
        sum=sum%10;
        cout<<sum<<endl;
        }
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值