7-2 有趣的队列 (25 分)
本题重新定义队列出队的操作:队首出队的数字重新在队尾入队。
例:队列中有1 2 3
三个数字,现要求队首出队,则1
从队首出队,同时1
从队尾入队,队列变成2 3 1
。
入队的顺序为1,2,3,4......n,同时给一个二进制字符串,1代表出队操作,0代表入队操作。
输入格式:
在第一行有两个数字n,m(n<=100,n<m),其中n为入队的数字个数,m代表操作数
接下来m行,每行一个数字,1或者0,代表不同的操作
输出格式:
输出操作后队列的每个数字,数字间以空格分隔,最后一个数字后没有空格
输入样例:
5 8
0
0
1
0
1
0
1
0
输出样例:
3 2 4 1 5
#include<iostream>
#include<string>
using namespace std;
#include<stdlib.h>
#define MAXQSIZE 100
#define ok 1
typedef int status;
typedef int QElemType;
typedef struct QNode
{
QElemType data;
struct QNode *next;
}QNode,*QueuePtr;
typedef struct
{
QueuePtr front;
QueuePtr rear;
}LinkQueue;
status InitQueue(LinkQueue &Q)
{
Q.front=Q.rear=new QNode;
Q.front->next = NULL;
return ok;
}
status EnQueue(LinkQueue &Q,QElemType e)
{
QNode *p = new QNode;
p->data = e;
p->next = NULL;
Q.rear->next = p;
Q.rear = p;
return ok;
}
status DeQueue(LinkQueue &Q, QElemType &e)
{
if (Q.rear == Q.front) return 0;
QNode *p = Q.front->next;
e = p->data;
Q.front->next = p->next;
if (Q.rear == p) Q.rear = Q.front;
delete p;
return ok;
}
QElemType GetHead(LinkQueue Q)
{
if (Q.front != Q.rear)
return Q.front->next->data;
}
status printQueue(LinkQueue Q)
{
QNode *p =Q.front->next;
while (p)
{
if(p->next==NULL)
cout<<p->data;
else
cout<<p->data<<" ";
p = p->next;
}
}
int main()
{
LinkQueue Q;
InitQueue(Q);
int n,m,r=1;
cin>>n>>m;
for(int i=1;i<=m;i++)
{
int x;
cin>>x;
if(x==0)
{
EnQueue(Q,r++);
}
if(x==1)
{
int c=GetHead(Q);
DeQueue(Q,c);
EnQueue(Q,c);
}
}
printQueue(Q);
}