[POJ](1064)Cable master ---二分查找(查找)

Cable master
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50208 Accepted: 10558

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00


解题新知:

①题意:有N条绳子,它们的长度分别为Li。如果从它们中切割K条长度相等的绳子的话,这K条绳子的每条最长能有多长?答案保留到小数点后两位。

②思路:看了《挑战程序设计竞赛》的这道题解析,扩宽了一下自己的视野。我从学习到二分查找这个算法,不仅可以在有序数列中查找Key值,在求解最优解的问题上也非常有用!比如这道题,我们可以令条件C(x)=可以得到K条长度为x的绳子。那么所求问题就变成了-----求满足C(x)条件的最大的x。在区间初始化时,只要使用充分大的数INF(>MAXL)做区间上界。即l=0,r=INF;由于长度为Li的绳子最多可以切成floor(Li/x)段长度为x的绳子。因此

C(x)=(floor(Li/x)的总和是否大于或等于K)。


AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#define MAX 10005
const double INF=100005.0;
using namespace std;
int n,k;
double l[MAX];
bool flag(double x)
{
    int sum=0;
    for(int i=0;i<n;i++)
        sum+=(int)(l[i]/x);
    return sum>=k;
}
void bSearch()
{
    double mid;
    double l=0;
    double r=INF;
    for(int i=0;i<100;i++)  //代替while(r>l) 避免了精度问题 ,1次循环可以把区间缩小一半,100次可以达到10^(-30)的精度
    {
        mid=(l+r)*1.0/2;
        if(flag(mid))
            l=mid;
        else
            r=mid;
    }
    printf("%.2f\n",floor(r*100)/100);
}
int main()
{
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%lf",&l[i]);
        bSearch();
    }
    return 0;
}




转载于:https://www.cnblogs.com/WangMeow/p/7535959.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值