poj 1064 Cable master(浮点数的二分法)

3 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34248 Accepted: 7278

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

Northeastern Europe 2001


题目大意:

       n个木棍,切成出k个等长的段,问最大切多长。但这不重要!

解题思路:

       对木棍的长度进行二分,但这个也不重要!

       重要的是精度问题。

      首先,计算每根木棍能截取出来的段数的时候,精度上就有一个悖论一样的问题:假如说能截出来的段数是16.0000,但是除法可能会计算出来15.9999999,所以要加上一个eps保证这种误差不存在。但是可能截得来的段数确实不到16,只有15.99999段,那我只能得到15段,又不能加上eps了,汗。。

      之后,我发现floor(l*100)/100.0!=(int)(l*100)/100.0,因为前者能过,后者过不了,但实际上这句的作用都是求解精确答案对0.01下取整的结果。。。

     

#include<stdio.h>
#include<math.h>
double a[10005];
int N,K;
int piece(double x)
{
    int cnt=0;
    for(int i=0;i<N;i++)
        cnt+=(int)(a[i]/x+1e-10);
    return cnt;
}
int main()
{
    double l=0.00,r=-1;
    int t=200;
    scanf("%d%d",&N,&K);
    for(int i=0;i<N;i++)
    {
        scanf("%lf",&a[i]);
        r=r>a[i]?r:a[i];
    }
    while(t--)
    {
        double mid=(r+l)/2;
        if(piece(mid)>=K)l=mid;
        else r=mid;
    }
    printf("%.2lf\n",floor(l*100)/100.0);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值