[POJ](2506)Tiling ---递推+Java大数

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10510 Accepted: 4891

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251


解题新知:

       ①:递推过程,当最左边只有一根竖的2x1,那么剩下的方案数是f[i-1];当最左边只有一个2x2时,那么剩下的方案数是f[i-2];当最左边只有两根横的2x1时,那么剩下的方案数是f[i-2];即f[i]=f[i-1]+2*f[i-2];

       :注意,f[0]=1,这点实际意义不好懂,那么反推,f[1]=1,f[2]=3,即2*f[0]=(f[2]-f[1])  f[0]=1;



AC代码:

import java.math.*;
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		BigInteger[] f = new BigInteger[1005];
		f[0] = BigInteger.ONE;
		f[1] = BigInteger.ONE;
		BigInteger b = new BigInteger("2");
		for(int i=2;i<=300;i++) {
			f[i]=f[i-1].add(f[i-2].multiply(b));
		}
		while(in.hasNextInt()) {
			int n = in.nextInt();
			System.out.println(f[n]);
		}
	}
}


转载于:https://www.cnblogs.com/WangMeow/p/7535941.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值