POJ2506 JAVA大数

题目

Description
In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.
这里写图片描述
Input
Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output
For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input
2
8
12
100
200

Sample Output
3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

题意
2*n的长方形内铺2*1和2*2的长方形,问有多少种铺法

题解
递推公式f(n)=f(n-1)+2*f(n-2)

BigInteger使用方法
1、初始化BigInteger

BigInteger bigInteger=new BigInteger("1");

2、赋值

bigInteger=BigInteger.valueOf(1);

3、运算

bigInteger=bigInteger.add(BigInteger.valueOf(1));   //加
bigInteger=bigInteger.subtract(BigInteger.valueOf(1));  //减
bigInteger=bigInteger.multiply(BigInteger.valueOf(1));  //乘
bigInteger=bigInteger.divide(BigInteger.valueOf(1));    //除
bigInteger=bigInteger.mod(BigInteger.valueOf(1));   //取余

代码

import java.math.BigInteger;
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        BigInteger bigInteger[]=new BigInteger[300];
        bigInteger[0]=BigInteger.valueOf(1);
        bigInteger[1]=BigInteger.valueOf(1);
        bigInteger[2]=BigInteger.valueOf(3);
        for(int i=3;i<=250;i++){
            bigInteger[i]=bigInteger[i-1].add(BigInteger.valueOf(2).multiply(bigInteger[i-2]));
        }
        Scanner scanner=new Scanner(System.in);
        while(scanner.hasNext()){
            int x=scanner.nextInt();
            System.out.println(bigInteger[x]);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值