[SOJ] can I post the letter?

1155. Can I Post the letter

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

I am a traveler. I want to post a letter to Merlin. But because there are so many roads I can walk through, and maybe I can’t go to Merlin’s house following these roads, I must judge whether I can post the letter to Merlin before starting my travel. 

Suppose the cities are numbered from 0 to N-1, I am at city 0, and Merlin is at city N-1. And there are M roads I can walk through, each of which connects two cities. Please note that each road is direct, i.e. a road from A to B does not indicate a road from B to A.

Please help me to find out whether I could go to Merlin’s house or not.

 

Input

 

There are multiple input cases. For one case, first are two lines of two integers N and M, (N<=200, M<=N*N/2), that means the number of citys and the number of roads. And Merlin stands at city N-1. After that, there are M lines. Each line contains two integers i and j, what means that there is a road from city i to city j.

The input is terminated by N=0.

 

Output

For each test case, if I can post the letter print “I can post the letter” in one line, otherwise print “I can't post the letter”.

Sample Input

3
2
0 1
1 2
3
1
0 1
0

Sample Output

I can post the letter
I can't post the letter


利用Dijiskra算法解决问题

#include<iostream>
#include<memory>
using namespace std;

const int MAX = 205;
int edge[MAX][MAX];
bool visited[MAX];
int n, m;

void DFS(int current)
{
   for(int i=0;i<n;i++)
   {
    if(!visited[i]&&edge[current][i])
    {
      visited[i]=true;
      DFS(i);
    }
   }
}

int main()
{
  while(cin>>n&&n!=0&&cin>>m)
  {
    memset(edge, 0, sizeof(edge));
    memset(visited, false, sizeof(visited));
    int a, b;

    for(int i=0;i<m;i++)
    {
      cin>>a>>b;
      edge[a][b]=1;
      edge[b][a]=1;
    }
    visited[0]=true;

    DFS(0);

    if(visited[n-1])cout<<"I can post the letter\n";
    else cout<<"I can't post the letter\n";
  }

  return 0;
}

 

转载于:https://www.cnblogs.com/KennyRom/p/6245769.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值