sicily1155. Can I Post the lette

1155. Can I Post the lette

 

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

I am a traveler. I want to post a letter to Merlin. But because there are so many roads I can walk through, and maybe I can’t go to Merlin’s house following these roads, I must judge whether I can post the letter to Merlin before starting my travel. 

Suppose the cities are numbered from 0 to N-1, I am at city 0, and Merlin is at city N-1. And there are M roads I can walk through, each of which connects two cities. Please note that each road is direct, i.e. a road from A to B does not indicate a road from B to A.

Please help me to find out whether I could go to Merlin’s house or not.

 

Input

 

There are multiple input cases. For one case, first are two lines of two integers N and M, (N<=200, M<=N*N/2), that means the number of citys and the number of roads. And Merlin stands at city N-1. After that, there are M lines. Each line contains two integers i and j, what means that there is a road from city i to city j.

The input is terminated by N=0.

 

Output

For each test case, if I can post the letter print “I can post the letter” in one line, otherwise print “I can't post the letter”.

Sample Input

3
2
0 1
1 2
3
1
0 1
0

Sample Output

I can post the letter
I can't post the letter

Problem Source

ZSUACM Team Member

 

题目分析:一次搜索,拓扑即可完成。

 

参考代码:

#include <iostream>
#include <queue>
#include <cstring>
using namespace std;

struct R
{
    int beg;
    int end;
};

int main()
{
    int n, m;
    bool vis[200];
    while (1)
    {
        memset(vis, false, sizeof(vis));
        cin >> n;
        if (n == 0) break;
        cin >> m;
        R road[m];
        for (int i = 0; i < m; ++ i)
        {
            cin >> road[i].beg >> road[i].end;
        }
        vis[0] = true;
        queue<int> q;
        q.push(0);
        while (!q.empty() && !vis[n - 1])
        {
            int temp = q.front();
            for (int i = 0; i < m; ++ i)
            {
                if (temp == road[i].beg)
                {
                    int tem = road[i].end;
                    if (!vis[tem])
                    {
                        q.push(tem);
                        vis[tem] = true;
                    }
                }
            }
            q.pop();
        }
        if (vis[n - 1])
        {
            cout << "I can post the letter" << endl;
        }
        else
        {
            cout << "I can't post the letter" << endl;
        }
        
    }
}                                 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
算法sicily例题 1000. sicily 1155. Can I Post the lette Time Limit: 1sec Memory Limit:32MB Description I am a traveler. I want to post a letter to Merlin. But because there are so many roads I can walk through, and maybe I can’t go to Merlin’s house following these roads, I must judge whether I can post the letter to Merlin before starting my travel. Suppose the cities are numbered from 0 to N-1, I am at city 0, and Merlin is at city N-1. And there are M roads I can walk through, each of which connects two cities. Please note that each road is direct, i.e. a road from A to B does not indicate a road from B to A. Please help me to find out whether I could go to Merlin’s house or not. Input There are multiple input cases. For one case, first are two lines of two integers N and M, (N<=200, M<=N*N/2), that means the number of citys and the number of roads. And Merlin stands at city N-1. After that, there are M lines. Each line contains two integers i and j, what means that there is a road from city i to city j. The input is terminated by N=0. Output For each test case, if I can post the letter print “I can post the letter” in one line, otherwise print “I can't post the letter”. Sample Input 3 2 0 1 1 2 3 1 0 1 0 Sample Output I can post the letter I can't post the letter Source Code #include <iostream> #include <vector> using namespace std; int n,m; vector<int> vout[200]; bool visited[200]; bool flood(int u) { visited[u]=1; if (u==n-1) return 1; for (int x=0; x<vout[u].size(); x++) { int &v=vout[u][x]; if (!visited[v] && flood(v)) return 1; } return 0; }

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值