二分法的应用:最大化最小值 POJ2456 Aggressive cows

/*
二分法的应用:最大化最小值  POJ2456 Aggressive cows

Time Limit: 1000MS        Memory Limit: 65536K
Total Submissions: 18125        Accepted: 8636
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output

* Line 1: One integer: the largest minimum distance
Sample Input

5 3
1
2
8
4
9
Sample Output

3
Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.
Source

USACO 2005 February Gold
 */

import java.util.Arrays;
import java.util.Scanner;

public class Main {
    static int N, M;
    static int[] a;

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        N = sc.nextInt();
        M = sc.nextInt();
        a = new int[N];
        for (int i = 0; i < N; i++)
            a[i] = sc.nextInt();
        sc.close();
        Arrays.sort(a);
        int low = -1, high = 1000000001;
        while (high - low > 1) {
            int mid = (low + high) / 2;
            if (C(mid)) {
                low = mid;
            } else {
                high = mid;
            }
        }
        System.out.println(low);
    }

    static boolean C(int X) {
        int last = 0;
        for (int i = 1; i < M; i++) {
            int next = last + 1;
            while (next < N && a[next] - a[last] < X) {
                next++;
            }
            if (next >= N) return false;
            last = next;
        }
        return true;
    }
}

 

转载于:https://www.cnblogs.com/Alpharun/p/8663510.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值