Common Subsequence--poj--1458

Common Subsequence

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 17815

 

Accepted: 6847

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab

programming    contest

abcd           mnp

Sample Output

4

2

0

Source

Southeastern Europe 2003

 

解题思路:这是个求最长公共子序列长度的问题,首先要知道子序列不一定必须是连续的,即中间可以被其他字符分开,但它们的顺序必须是正确的。另外,最长公共子序列不一定只有一个,而我们要寻找的是其中之一就够了。

此题是典型的动态规划问题,我们先考虑输入序列S1S2的前缀序列:

c[i, j] = |LCS(S1[1..i], S2[1..j])|,则有c[m, n] = |LCS(S1, S2)|

仔细观察我们可以发现递推式:

c[i, j] = c[i-1, j-1] + 1,                        如果S1[i] = S2[j]

          =max{c[i-1, j], c[i, j-1]},                如果S1[i] != S2[j]

因此我们获得了该问题的最优子结构特性,即一个最优解决方案包含了子问题的最优解决方案,也就是说,如果CS=LCS(S1, S2),则CS的任何前缀子串必是S1S2的某个前缀的最长公共子序列。

通过分析我们还可以知道该递归包含了重复的子问题,因此我们就可以使用DP来降低复杂度。

计算最长公共子序列长度的DP算法如下:

初始化c[i, j]0<=i<=m, 0<=j<=n

for    i=1 to m do

         for j=1 to n do

                   if S1[i]==S2[j] then

                            c[i, j] = LCS[S1, S2, i-1, j-1] + 1  (c[i-1, j-1] + 1)

                   else if c[i-1, j] <= c[i, j-1] then

                            c[i, j] = c[i, j-1]

                   else

                            c[i, j] = c[i-1, j]

 

代码如下:

#include <iostream>

#include <string>

 

std::string str1;

std::string str2;

int num[256][256]; //数组开低了会出现Runtime Error

 

int lcs(std::string s1, std::string s2, int m, int n)

{

        

         for(int i=1; i<=m; i++)//此处需从1开始,因为下面循环有num[i-1][j-1]是最小的

         {

                   for(int j=1; j<=n; j++)

                   {

                            if(s1[i-1] == s2[j-1])

                            {

                                     num[i][j] = num[i-1][j-1] + 1;      

                            }       

                            else

                            {

                                     if(num[i][j-1] < num[i-1][j])

                                     {

                                               num[i][j] = num[i-1][j];       

                                     }       

                                     else

                                     {

                                               num[i][j] = num[i][j-1];

                                     }

                            }

                           

                   }       

         }

         return num[m][n];

}

 

int main()

{

         int len1, len2;

        

         while(std::cin>>str1>>str2)

         {

                   memset(num, 0, sizeof(num));

                   len1 = str1.length();

                   len2 = str2.length();

                   int out = lcs(str1,str2,len1,len2);

                   std::cout<<out<<std::endl;     

                  

         }

        

         system("pause");

         return 0;

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值