HDU 1029

这个题真的是被kuangbin大神震撼了,人和人真的是不一样啊

此题看百度上的其他题解,好像用快速排序可以过,也可以开一个数组记录每个数出现次数,然后查找出现次数最大的数就行了,好像是说题目中的数不超过1000010,具体是否能过我也不清楚,感觉时间上应该不会超时,是时间复杂度是O(n)的算法

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 6518    Accepted Submission(s): 2325


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
3 5 1


据kuangbin大神所说,如果一个数出现了(N+1)/2次,那么每次在这个数列中删去两个不相同的数,出现次数最多的数不改变,于是就有了下面的代码

#include<stdio.h>
#include<string.h>
using namespace std;

int main(){
	int n;
	while(~scanf("%d",&n)){
		int re;
		int cnt=0;
		int t;
		for(int i=0;i<n;i++){
			scanf("%d",&t);
			if(cnt==0){
				cnt=1;
				re=t;
			}
			else if(re!=t){
				cnt--;
			}
			else if(re==t) cnt++;
		}
		printf("%d\n",re);
	}
}
讲真,动态规划是真的难想,不过代码倒是很简洁
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值