HDU-1029-Ignatius and the Princess IV(C++ && 小技巧)

206 篇文章 0 订阅
78 篇文章 0 订阅

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 20489    Accepted Submission(s): 8441


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
  
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
  
  
3 5 1
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1040  1074  1003  1028  1171 

题目的主要意思是:
第一行读入一个N,N为奇数,然后下一行读入N个数,构成一组数列,
然后你的目的就是求出这组数列中出现次数至少为(N+1)/2次的那个数,
值得注意的是测试数据庞大,一不小心就会超时!

看了两种算法,第一种是利用数组存储,然后直接n+1/2的下一个数,输出!
虽然能过,但是个人觉得题目又没有其他条件,这也太水了......


第二种算法如下:
(代码来源网络,非本人原创)
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int nums;
    while(cin>>nums)
    {
        int cur,max=0,count=0;
        for(int i=0;i<nums;i++)
        {
            cin>>cur;
            if(count==0)
            {
                max=cur;
                count++;
            }
            else
            {
                if(cur!=max)
                {
                    count--;
                }
                else
                {
                    count++;
                }
            }
        }
        cout<<max<<endl;
    }
    return 0;
}


这个方法的思路是这样的,读入的数字,遇到相同的count++,不同则count--,一旦count==0
则换下一个数作为max,因为n是一个奇数,要求一个数至少出现(n+1)/2次。用count来记录
出现的次数,则出现的正确解的次数一定是不小于1的。为什么呢?因为正确解至少出现(n+1)/2次,
即使最后n+1/2-1个数全部与前面那个数不相同,count也不会为0.
例如:
 11
 3 3 3 3 3 3 9 5 1 2 7
 当max = 3时候,count=6,即使最后 count=1也不会为0,max=3!也就不会进入(count==0)这个模块了!
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值