HDU 1260

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 
InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am

题目大意:可以一次卖一张票,也能卖相邻的两人两张票,现在有k个人,下面k个数是每个人买票花费时间,然后k-1个数是,第i个人和i+1个人买票所花时间

dp的表达式非常容易推出来,两人的下标从1开始,表示i和i-1个人买票的时间,用dp[i]表示第i个人买完票最快要多少时间,那么dp[i]=max(dp[i-1]+a[i],dp[i-2]+b[i]),a[i]是第i个人花费时间,b[i]是两人花费时间,最后dp[k-1]就是最快时间。要注意一下初始化的状态

这题要注意输出格式里面中午十二点是pm,专门去百度了,真是坑人啊

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
#define INF 0x3f3f3f3f
int a[2005];
int b[2005];
int dp[2005];
void func(int t){
//	printf("%d\n",t);
	int h=8;
	int m=0;
	int s=0;
	int ju=0;
	for(int i=t;i>0;i--){
		s++;
		if(s>=60) {
			m++;
			s-=60;
		}
		if(m>=60){
			h++;
			m-=60;
		}
		if(h==12) ju=(ju+1)%2;
		if(h>12){
			h-=12;
		}
	}
	printf("%02d:%02d:%02d ",h,m,s);
	if(ju==1)printf("pm\n");
	else printf("am\n");
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int k;
		scanf("%d",&k);
		for(int i=0;i<k;i++) scanf("%d",&a[i]);
		for(int i=1;i<k;i++) scanf("%d",&b[i]);
		for(int i=0;i<k;i++){
			if(i==0) dp[i]=a[i];
			else if(i==1) dp[i]=min(dp[i-1]+a[i],b[i]);
			else dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
		} 
		func(dp[k-1]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值