HDU 1160

这是今天最后一篇了,今天写了不少题啊,有点累了,回去休息一会吧


FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing. 
InputInput contains data for a bunch of mice, one mouse per line, terminated by end of file. 

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. 

Two mice may have the same weight, the same speed, or even the same weight and speed. 
OutputYour program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]] 

and 

S[m[1]] > S[m[2]] > ... > S[m[n]] 

In order for the answer to be correct, n should be as large as possible. 
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7

题目大意:找出体重增加,但是速度减少的最长序列,并且输出(答案不唯一)

题解:先按照体重升序排列,然后再找出按速度的最长递减序列就可以了,这里有一点注意的就是如果体重相同,按速度的递增排序,因为等下是严格递减,那么如果按速度递减就会把一些体重相同但是速度递减的计入结果,这是不符合题目要求的

因为要找到这个序列包括那些元素,那么我们在存储数据的时候要顺便记录这是几号小鼠,不然排序后顺序被打乱,就造成数据丢失了,用last[i]记录第i个小鼠的上一个小鼠编号,然后在更新dp[i]时顺便更新last[i](last[i]初始化为-1,这样最后找到-1说明序列已经结束了),最后找到dp[i]最大的小数编号,将其编号和它上一个小鼠编号压入栈中,直到出现-1,然后再输入栈中元素就可以了

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

int dp[1005];
int last[1005];
struct R{
	int s;
	int v;
	int num;
}; 
int cmp(R a,R b){
	if(a.v!=b.v) return a.v<b.v;
	else return a.s<b.s;
}
R a[1005];

int main(){
	int n=0;
	memset(last,-1,sizeof(last));
	while(~scanf("%d%d",&a[n].v,&a[n].s)) {
		a[n].num=n+1;
		n++;
	}
	sort(a,a+n,cmp);
	for(int i=0;i<n;i++) dp[i]=1;
	for(int i=1;i<n;i++){
		for(int j=0;j<i;j++){
			if(a[i].s<a[j].s){
				if(dp[i]<dp[j]+1){
					dp[i]=dp[j]+1;
					last[a[i].num]=a[j].num;
				}
			}
		}
	}
	int Max=0,jj=0;
	for(int i=0;i<n;i++){
		if(dp[i]>Max){
			Max=dp[i];
			jj=a[i].num;
		}
	}
	printf("%d\n",Max);
	int sta[1005];
	int top=0;
	for(int i=jj;i!=-1;i=last[i]){
		sta[top++]=i;
	}
	while(top>0){
		printf("%d\n",sta[--top]);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值