1394_Polar Explorer

Introduction

You are a intrepid 2-dimensional explorer located at the northern polar reaches of a distant 2-dimensional planet. Unfortunately, you have been assigned to explore the most boring planet in the known universe (due primarily to your lack of social skills and aggressive body odor). Having a perfectly circular surface, your planet holds no surprises for a would-be explorer.

However, you have recently received a distress call from an alien ship which has crash-landed somewhere on the surface of your planet. Unfortunately, you designed your own equipment, and the only information it will give you is an angle (measured from the center of the planet) separating you from the crash site.

Using this information along with how much gasoline is available for your planet-rover (which gets a measley 5 miles per gallon), you have to determine if you can possibly get to the crash site and back without running out of fuel.



Input


Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 3 components:

Start line - A single line, "START".

Input line - A single line, "X Y Z", where:

X : (1 <= X <= 100) is the radius of your planet in integer miles

Y : (0 <= Y <= 100) is the amount of gasoline in your planet-rover in integer gallons

Z : (0 <= Z <= 360) is an angle separating you from the crash site in integer degrees

End line - A single line, "END".

Following the final data set will be a single line, "ENDOFINPUT".


Take note of the following:

The circumference of a circle in terms of its radius, r, is known to be 2��r

Assume that �� = 3.14159


Output

For each data set, there will be exactly one line of output. If you have enough fuel to get to the crash site and back, the line will read, "YES X" where X is the amount of fuel you will have left expressed as an integer number of gallons (truncate any fractional gallons). If you do not have sufficient fuel, the line will read, "NO Y" where Y is the distance you can travel expressed as an integer number of miles.


Sample Input

START
1 100 0
END
START
10 0 1
END
START
100 50 90
END
START
100 50 270
END
ENDOFINPUT


Sample Output

YES 100
NO 0
NO 250
NO 250


××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××

#include<iostream>

#include<string>
#define pi 3.14159
using namespace std;
int main()
{
string s1,s2;
int x,y,z;
    double dis,aa;
while(cin>>s1&&s1.size()==5)
{
       cin>>x>>y>>z>>s2;
  if(z>180)
  z=360-z;
  aa=z;//必须将int转换为double,否则下面z/360取整=0;
  dis=2*pi*x*(aa/360);//距离为什么是曲线而不是直线?
  if(5*y>=2*dis)
  {
  y=y-2*dis/5;
  cout<<"YES"<<" "<<y<<endl;
  }
  else
  cout<<"NO"<<" "<<5*y<<endl;
}
return 0;
}
### Inertial Explorer Software Overview Inertial Explorer is a comprehensive software suite designed for the processing and analysis of data from inertial navigation systems (INS). It provides tools to analyze, visualize, and post-process INS data collected during various missions or experiments. The software supports high-precision positioning, orientation, and motion tracking in complex environments where GPS signals may be unavailable or unreliable. The primary functionalities include calibration of inertial measurement units (IMUs), trajectory reconstruction, sensor fusion with external inputs such as GNSS, odometer, and DVL sensors, and error modeling for improved accuracy over time[^2]. Additionally, it offers advanced filtering techniques like Kalman filters to optimize state estimation under dynamic conditions. For mobile robot navigation applications mentioned earlier regarding uniform polar sampling methods within state space exploration [^1], integrating an INS solution processed through Inertial Explorer could enhance performance by providing robust odometry estimates even amidst challenging terrains or occluded areas without reliable global positioning assistance. ### Example Code Demonstrating Basic Data Processing Workflow Using Python Below demonstrates how one might simulate loading IMU/INS type datasets into memory followed by applying basic smoothing operations which can represent part of what would occur inside specialized packages similar to those functions performed via commercial offerings including 'Inertial Explorer'. ```python import numpy as np from scipy.signal import savgol_filter def load_ins_data(file_path): """Simulate reading raw INS dataset.""" return np.loadtxt(file_path) def smooth_trajectory(data, window_length=5, polyorder=2): """Apply Savitzky-Golay filter on positional data.""" smoothed_positions = savgol_filter(data[:, :3], window_length, polyorder) return np.hstack((smoothed_positions, data[:, 3:])) # Hypothetical usage example assuming file contains timestamp,x,y,z,vx,vy,vz columns. ins_raw = load_ins_data('path_to_your_file.txt') processed_data = smooth_trajectory(ins_raw) print(processed_data[:5]) # Display first five rows after processing step applied above. ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值