1796_Euchre Results(有收获)

Anna, Betty, Cindy and Zelda like playing the card game Euchre. Euchre is a game for two teams of two, and each time they meet the girls split off into different teams. They also keep overall records of the number of games each player has won and lost. Anna has misplaced her won-loss results, but she does have the results of the other three players. Given this, she figures she can determine her won-loss record.


Input

Input will consist of multiple problem instances. Each instance will consist of a single line containing six integers. The first two are the number of wins and losses (respectively) for Betty, the next two are the number of wins and losses for Cindy and the last two are the number of wins and losses for Zelda. A final line of six zeroes will terminate input and should not be processed.


Output

For each problem instance, output a single line indicating Anna's won-loss record, in the format shown in the example below.


Sample Input

10 3 6 7 8 5
1874 2945 2030 2789 1025 3794
0 0 0 0 0 0


Sample Output

Anna's won-loss record is 2-11.
Anna's won-loss record is 4709-110.


Source: East Central North America 2003, Practice

××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××××

//四个人总共输赢的次数是回合次数的四倍,且输赢对半分,然后减去其他三个的
#include<iostream>
using namespace std;
int main()
{
int score[6];
int i,num,count;
while(true)
{   
count=0;
for(i=0;i!=6;i++)
{
cin>>num; 
score[i]=num;
if(num==0)  
  ++count;//记录有6个零才表示退出,此题在一组输入的刚开始出现0并不能表明就是输入的结束(第一个人的胜场可能为0),必须全部6个数都为0
}
if(count!=6)
  cout<<"Anna's won-loss record is "<<2*(score[0]+score[1])-score[0]-score[2]-score[4]<<"-"<<2*(score[0]+score[1])-score[1]-score[3]-score[5]<<"."<<endl;
else 
break;
}
return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值