POJ1001

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 163147 Accepted: 39597

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


题目分析

1.数比较大,采用高精度算法。

2.考虑整数部分是0的情况,小数部分末尾有0的情况,以及输出结果是整数的情况

代码清单(转载,自己进行标注)

#include <iostream>  
#include <string>  
#include <algorithm>  
#include <fstream>  
using namespace std;  
const int MAX_LEN = 1000;  
int ia[MAX_LEN];  
  
string subF(string str1, string str2)  
{      
     int i,j;  
     string result;  
     memset(ia,0,sizeof(ia));     // 数组初始化 
  
     reverse(str1.begin(), str1.end());     // 倒置  
     reverse(str2.begin(), str2.end());  
  
     int point1, point2,point;               //     小数位数  
     point1 = str1.find('.');      //不存在小数点时find()返回值为-1 
     point2 = str2.find('.');  //存在小数点时find()返回值为所在位置的下标(起点为0) 
     if(point1 != string::npos)               // 如果为小数,则将小数点删除  
          str1.erase(str1.begin()+point1);  
     else  
          point1 = 0;  //不存在,置小数点下标为0; 
     if(point2 != string::npos)  
          str2.erase(str2.begin()+point2);  
     else  
          point2 = 0;  
     point1 > point2 ? point = point1 : point = point2;     // point保存最大的小数位数  
  
     int len1 = str1.size();  //数长度 
     int len2 = str2.size();  
      
     for(i = 0; i < len1; i++)               // 乘法运算  
          for(j = 0; j < len2; j++)  
               ia[i+j] += (str1[i]-'0')*(str2[j]-'0');  //模拟笔算,对应位相乘 
  
     int len;     // 乘积的长度  
     for(i = 0; i < len1+len2; i++)          // 进位处理  
     {  
          if(ia[i] >= 10)  
          {  
               ia[i+1] += (ia[i]/10);  
               ia[i] %= 10;  
          }  
     }  
     if(ia[len1+len2-1] > 0)  //判断倒置后的末位 是否为0 
          len = len1+len2;  
     else  
          len = len1+len2-1;  
  
     for(i = len-1; i >= 0; i--)  //将处理后的结果倒置 
          result += char(ia[i]+'0');  
     if(point > 0)          // 插入小数点  
     {  
          result.insert(result.end()-point1-point2,'.');  
          for(i = result.size()-1; i >= 0; i--)     // 去除小数点后的后置0  
          {  
               if(result[i] == '0')  
                    result.erase(result.begin()+i);  
               else if(result[i] == '.')  //输出结果是整数 ,则需要去掉小数点 
               {  
                   result.erase(result.begin()+i);  
                   break;  
               }  
               else  
                    break;  
          }  
          while( (*result.begin()) == '0' )     // 去除小数点前的前置0  
              result.erase(result.begin());  
     }  
     return result;  
}  
  
int main()  
{  
     
      
     string str1;  
     int n;  
     while(cin >> str1 >> n)  
     {  
         string str2("1");  
         while(n--)  
         {  
           str2 = subF(str1, str2);  
         }  
          cout << str2 << endl;  
     }  
     system("pause");  
     return 0;  
}  




Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值