hash

Description

现在给出A,B,C,D四个集合,每个集合中元素的个数n都是相同的,现在从每个集合中任取出一个数,记为a,b,c,d,现在要求统计有多少组不同的(a,b,c,d)使得a+b+c+d=0。

Input

第一行为各集合中元素的个数n; 

第二行到第n+1行,每行有4个数字,依次为A,B,C,D中的一个元素。

a,b,c,d的绝对值小于1000000,n小于500。

Output

一行,为不同的(a,b,c,d)使得a+b+c+d=0的组数。

Sample Input

6-45 22 42 -16-41 -27 56 30-36 53 -37 77-36 30 -75 -4626 -38 -10 62-32 -54 -6 45

Sample Output

5
#include <iostream>
using namespace std;
#define maxlen 500
 
int main()
{
    int n;
    while (cin >> n)
    {
        int groupnum = 0;
        int A[maxlen];
        int B[maxlen];
        int C[maxlen];
        int D[maxlen];
        int AB[maxlen*maxlen];
        int CD[maxlen*maxlen];
        int hashtable[2 *maxlen* maxlen];
        int i, j,count=0;
        //初始化hashtable
        for (i = 0; i < 2 * maxlen*maxlen; i++)
            hashtable[i] = 1000002;
 
        for (i=0; i < n; i++)
            cin >> A[i] >> B[i] >> C[i] >> D[i];
 
        for (i = 0; i < n; i++)
            for (j = 0; j < n; j++)
            {
                AB[count] = A[i] + B[j];
                count++;
            }
 
        count = 0;
        for (i = 0; i < n; i++)
            for (j = 0; j < n; j++)
            {
                CD[count] = C[i] + D[j];
                count++;
            }
        //以上数组均正确
 
 
        //hash
        for (i = 0; i < n*n; i++)
        {
            int temp = CD[i] % maxlen;
            while (hashtable[temp] != 1000002)
                temp++;
            hashtable[temp] = CD[i];
        }
 
        for (i = 0; i < n*n; i++)
        {
            int templ =( -AB[i]) % maxlen;
            while (hashtable[templ] != 1000002)
            {
                if ((AB[i]+ hashtable[templ])==0)
                {
                    groupnum++;
                        break; 
                }
                templ++;
            }
        }
        cout << groupnum << endl;
    }
    return 0;
}
/**************************************************************
    Problem: ****
    User: ****
    Language: C++
    Result: Accepted
    Time:4 ms
    Memory:5124 kb
****************************************************************/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值