poj_1730_Perfect Pth Powers

We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2




一点都不难但是很讨厌的一道题,很烦的地方就是输入可以为负,没有处理搞了半天runtime error。
然后输入用longlong。
对于输入为负的数字。例64=2^6,然而-64=(-4)^3。
综上,负数的output只能为奇数
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#define N 100001
using namespace std;
typedef long long ll;
bool vis[N];
int prime[N];
int pn=0;
int gcd(int a,int b)
{
    if(!b) return a;
    return gcd(b,a%b);
}
int main()
{
    for (int i = 2; i < N; i++) {
        if (vis[i]) continue;
        prime[pn++] = i;
    for (int j = i; j < N; j += i)
            vis[j]=1;
    }
    ll n;
    while(~scanf("%lld",&n),n)
    {
        ll r=n>0?n:-n;
        int ans=0;
        for(int i=0;(long long)prime[i]*prime[i]<=r;i++)
        {
            int tem=0;
            while(r%prime[i]==0)
            {
                r/=prime[i];
                tem++;
            }
            if(tem)
                ans=gcd(ans,tem);
        }
        if(r!=1&&ans)
            ans=gcd(ans,r);
        if(!ans)
            ans++;
        if(n<0)
        {
            while(ans%2==0)
                ans/=2;
        }
        cout<<ans<<endl;
    }
}

  

转载于:https://www.cnblogs.com/ygtzds/p/7833589.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值