描述
给定两个正整数m、n,问只能做加1、乘2和平方这三种变化,从m变化到n最少需要几次
输入
输入两个10000以内的正整数m和n
输出
输出从m变化到n的最少次数
输入样例
1 16
输出样例
3
#include <iostream>
#include <queue>
using namespace std;
int m, n;
int visited[100000];
int bfs()
{
queue<int>q;
q.push(m);
visited[m] = 1;
while(!q.empty())
{
int temp = q.front();
q.pop();
if(temp == n)
return visited[n];
//本题的关键 新状态值小于n,否则指数级增长
if(temp+1 <= n && !visited[temp+1])
{
q.push(temp+1);
visited[temp+1] = visited[temp]+1;
}
if(temp*temp <= n && !visited[temp*temp])
{
q.push(temp*temp);
visited[temp*temp] = visited[temp]+1;
}
if(temp*2 <= n && !visited[temp*2])
{
q.push(temp*2);
visited[temp*2] = visited[temp]+1;
}
}
}
int main()
{
cin >> m >> n;
cout << bfs()-1 << endl;
}