All in All
Time Limit:1000MS Memory Limit:65536K
Total Submit:33 Accepted:9
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
iven two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No
Source
#include <stdio.h>
#include <string.h>
char c[100001], s[100001];
bool isSubstring(int c_i, int c_j, int s_i, int s_j)
{
int c_len = c_j-c_i, s_len = s_j-s_i;
if (c_len > s_len) return false;
int i;
for (i=s_i; i<=s_j; i++)
if (c[c_i] == s[i]){
if (c_len == 0) return true;
return isSubstring(c_i+1, c_j, i+1, s_j);
}
return false;
}
int main()
{
while (scanf("%s %s", c, s) == 2){
printf("%s\n", isSubstring(0, strlen(c)-1, 0, strlen(s)-1) ? "Yes" : "No");
}
return 0;
}