数据结构实验之链表四:有序链表的归并
TimeLimit: 1000MS Memory Limit: 65536KB
ProblemDescription
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
ExampleInput
65
123 26 45 66 99
1421 28 50 100
ExampleOutput
114 21 23 26 28 45 50 66 99 100
Hint
不得使用数组!
Author
D
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<stack>
#include<queue>
//#include<dqeue>
struct node
{
int data;
struct node*next;
};
struct node*creat(struct node*head,int n)
{
head= (struct node*)malloc(sizeof(struct node));
head->next =NULL;
struct node*tail = head;
for(int i=1;i<=n;i++)
{
struct node*p = (struct node*)malloc(sizeof(struct node));
p->next =NULL;
scanf("%d",&p->data);
tail->next = p;
tail = p;
}
return head;
}
struct node*guibing(struct node*head1,struct node*head2)
{
head1= head1->next;
head2 =head2->next;
struct node*tail,*p,*mail;
tail = (struct node*)malloc(sizeof(struct node));
mail = tail;
while(head1&&head2)
{
if(head1->data<head2->data)
{
mail->next = head1;
mail = head1;
p = head1;
head1 = head1->next;
p->next =NULL;
}
else
{
mail->next =head2;
mail = head2;
p = head2;
head2 = head2->next;
p->next =NULL;
}
}
if(head1)
{
while(head1)
{
mail->next =head1;
mail = head1;
p = head1;
head1 = head1->next;
p->next = NULL;
}
}
else if(head2)
{
while(head2)
{
mail->next =head2;
mail = head2;
p = head2;
head2 = head2->next;
p->next =NULL;
}
}
return tail;
}
void show(struct node*head)
{
struct node*tail;
tail =head;
int top = 1;
while(tail->next)
{
if(top)top=0;
else printf(" ");
printf("%d",tail->next->data);
tail = tail->next;
}
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
struct node*head1= (struct node*)malloc(sizeof(struct node));
struct node*head2 = (struct node*)malloc(sizeof(struct node));
head1 = creat(head1,n);
head2= creat(head2,m);
head1 = guibing(head1,head2);
show(head1);
return 0;
}
/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 152KB
Submit time: 2017-01-14 17:07:39
****************************************************/