sdutacm-求二叉树的深度

求二叉树的深度

TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic

Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output

输出二叉树的深度。

Example Input

2

dbgeafc

dgebfca

lnixu

linux

Example Output

4

3

Hint

 

Author

 

#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
typedef struct node
{
   char data;
   struct node*l;
   struct node*r;
}tree;
void huifu(char *zhong,char *hou,int len)//仅仅求出后序遍历树
{
  if(len==0)
  return ;
  tree *p = new tree;
  p->data = *(hou+len-1);
  int i = 0;
  for(;i<len;i++)
  if(zhong[i]==*(hou+len-1))
  {
     break;
  }
   cout<<p->data;
  huifu(zhong,hou,i);
  huifu(zhong+i+1,hou+i,len-i-1);

  return ;

}
tree* huifu3(char *zhong,char *hou,int len)//已知中序后序遍历,求出并建立以该树组成的(以后序建立的)树;
{
   tree*root = new tree;
   if(len==0)
   return NULL;
   root->data = *(hou+len-1);
   int i;
   for( i = 0; i < len ;i++)
   {
     if(zhong[i] == *(hou+len-1))
     break;
   }
   root->l = huifu3(zhong,hou,i);
   root->r = huifu3(zhong+i+1,hou+i,len-i-1);
  return root;
}
tree* huifu2(char *xian,char *zhong,int len)//同上已知先序中序建立前序树;
{
   tree*head =new tree;
   if(len==0)
   return NULL;

   head->data = *(xian);
   int i = 0;
   for(;i<len;i++)
   {
       if(zhong[i]==*xian)
       break;

   }
   head->l = huifu2(xian+1,zhong,i);
   head->r = huifu2(xian+i+1,zhong+i+1,len-i-1);
   return head;


}
void last(tree*root)/*后序遍历树*/
{

   if(root)
   {

      last(root->l);
      last(root->r);
      cout<<root->data;

   }

}
int high(tree*root)//递归求出树的高度
{
   if(!root)
   return 0;
   else
   return max(high(root->l),high(root->r))+1;

}
void ccout(tree*root)//层次遍历(从上到下,从左到右)先序树,并打印
{
    queue<tree*>q;
    tree*p =NULL;
    if(root)
    {
      q.push(root);
    }
    while(!q.empty())
    {
        p = q.front();
        q.pop();
        cout<<p->data;
        if(p->l)
        {
           q.push(p->l);
        }
        if(p->r)
        {

           q.push(p->r);
        }

    }



}
int main()
{

   char hou[102],zhong[102],xian[102];
   int o;
   cin>>o;
   while(o--)
   {

    int len;
   scanf("%s%s",zhong,hou);
   len = strlen(zhong);
   tree* root;
   root = huifu3(zhong,hou,len);
   int u = high(root);
   cout<<u<<endl;

   }


}






/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 160KB
Submit time: 2017-02-07 16:12:17
****************************************************/


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值