sdutacm-数据结构实验之栈四:括号匹配

数据结构实验之栈四:括号匹配

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
 给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

Input
 输入数据有多组,处理到文件结束。
Output
 如果匹配就输出“yes”,不匹配输出“no”
Example Input
sin(20+10){[}]
Example Output
yesno
Hint
 
Author
ma6174

 

1

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<stdlib.h>
#include<stack>
using namespace std;
int main()
{
    char s[52];


    //fgets(s,100,stdin);

    while(gets(s))
    {
       stack<char>t;
        int f = 0;
        for(int i=0; s[i]!='\0'; i++)
        {

            if(s[i]=='('||s[i]=='{'||s[i]=='[')
            {
                t.push(s[i]);
            }
            else if(s[i]==')')
            {

                if(t.empty())
                {
                    f = 1;
                    break;

                }
                else
                {
                    if(t.top()=='(')
                    {
                        t.pop();
                    }
                    else
                    {
                        f = 1;
                        break;

                    }


                }




            }
            else if(s[i]==']')
            {
                if(t.empty())
                {

                    f = 1;
                    break;

                }
                else

                {

                    if(t.top()=='[')
                    {
                        t.pop();


                    }
                    else
                    {
                        f= 1;
                        break;
                    }



                }


            }
            else if(s[i]=='}')
            {
                if(t.empty())
                {
                    f = 1;
                    break;


                }
                else
                {
                    if(t.top()=='{')
                    {

                        t.pop();

                    }
                    else
                    {
                        f = 1;
                        break;

                    }

                }




            }
            if(f == 1)
        {

            break;
        }
    }

   if(f==0&&t.empty())
   {
     printf("yes\n");

   }
   else
   printf("no\n");
    //fputs(s,stdout);

}




return 0;
}




/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 116KB
Submit time: 2017-01-13 09:59:31
****************************************************/

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值