hdu 4349 Xiao Ming's Ho

Xiao Ming's Ho

ime Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1155    Accepted Submission(s): 794

Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?
 
Input
Each line contains a integer n(1<=n<=108)
 
Output
A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).
 
Sample Input
1
2
11
 
Sample Output
2
2

8


题意

给定n,求C(n, 0) C(n, 1) ……C(n, n)中奇数的个数


解法

数学上有一个二项式系数的定理,即二项式系数中的奇数个数等于2^k(k为n的二进制表示中1的个数)。具体证明可以百度到。至于怎么算k,我用的lowbit(),相信看过树状数组的都知道这个,它表示x的二进制表示中右边第一个1的值,具体实现见代码。

我第一次做的时候也没找到规律,一发现这个定理就秒过。其实这种题多算几个例子,还是可以观察出来的。

#include "iostream"
#include "cstdio"
using namespace std;

int lowbit(int x)
{
	return x&(-x);
}

int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		int k = 1;
		while(n != 0)
		{
			n = n - lowbit(n);
			k = k << 1;
		}

		printf("%d\n", k);

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值