数据结构实验之查找七:线性之哈希表

Problem Description

根据给定的一系列整数关键字和素数p,用除留余数法定义hash函数H(Key)=Key%p,将关键字映射到长度为p的哈希表中,用线性探测法解决冲突。重复关键字放在hash表中的同一位置。

Input

连续输入多组数据,每组输入数据第一行为两个正整数N(N <= 1000)和p(p >= N的最小素数),N是关键字总数,p是hash表长度,第2行给出N个正整数关键字,数字间以空格间隔。

Output

输出每个关键字在hash表中的位置,以空格间隔。注意最后一个数字后面不要有空格。

Example Input
5 5
21 21 21 21 21
4 5
24 15 61 88
4 5
24 39 61 15
5 5
24 39 61 15 39
Example Output
1 1 1 1 1
4 0 1 3
4 0 1 2
4 0 1 2 0
#include <stdio.h>  
#include <stdlib.h>  
#include <string.h>  
  
int main()  
{  
    int n,p,i,j;  
    int ha[1100],a[1100];  
    while (~scanf ("%d %d",&n,&p))  
    {  
        memset (ha,0,sizeof (ha));  
        for (i=0; i<n; i++)  
        {  
            int d = 0;  
            scanf ("%d",&a[i]);  
            int t = a[i]%p;  
            if (!ha[t])  
            {  
                ha[t] = a[i];  
                printf ("%d",t);  
            }//if  
            else//当ha[t]位置被存储过的时候有两种情况,一种是通过线性探测法找到此元素已经被存储过的位置tmp,另一种是通过线性探测法找到下一个存储位置(t+d)%p  
            {  
                int tmp;  
                bool vis;  
                while (ha[(t+d)%p])  
                {  
                    vis = false;  
                    if (ha[(t+d)%p]==a[i])//此元素已经被存储过  
                    {  
                        tmp = (t+d)%p;//tmp为a[i]存储过的位置  
                        vis = true;  
                        break;  
                    }  
                    d++;  
                }  
                ha[(t+d)%p] = a[i];  
                if (vis)  
                    printf ("%d",tmp);  
                else printf ("%d",(t+d)%p);  
            }//else  
            if (i==n-1)  
                printf ("\n");  
            else  
            printf (" ");  
        }//for  
    }//for  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值