POJ3666 Making the Grade题解-动态规划dp

POJ3666 Making the Grade解题报告

Description

A straight dirt road connects two fields on FJ’s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, … , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . … , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

| A 1 - B 1| + | A 2 - B 2| + … + | AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

  • Line 1: A single integer: N
  • Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

  • Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

中文大意

农夫约翰想修一条尽量平缓(海拔单调增或单调减(非严格,下同))的路,路的每一段海拔是 Ai ,修理后是 Bi ,花费| AiBi |,求最小花费。

具体思路

该题目有两种情况:一种是变成单调增序列,一种是变成单调减序列。因此打算分两种情况进行计算:

以单调增为例。我们可以很容易证明得最终得出的序列的每一个元素都是原来序列中的某一个元素。即原序列 e1e2...en 得到最终结果 e1e2...en(e1e2...en) ,其中 ei{e1,e2,...,en}  。

 用反证法可以求得:若存在i使得  ei{e1,e2,...,en} ,但 ei1 或者 ei+1 可能更加接近 ei ,进一步想想看就可以证明正确性了。

所以可以列出dp状态转移方程:

dp[i][j]:= i 个数变成单调且最后一个数是Bj,此时的最小成本。

dp[i][j]=min(dp[i1][k])+|AiBj|(k=1,2,,j)

这对于单调减序列,亦然。

为了节省内存空间,我们不妨利用滚动数组求解。

参考代码

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>

using namespace std;
static const int N_MAX = 2001;
static const int INF = 1<<21;

int dp[2][N_MAX];
int A[N_MAX];
int B[N_MAX];

int N;
int solveUp()
{
    //init
    sort(B+1,B+N+1);
    for(int j=1;j<=N;j++)
    {
        dp[1][j] = abs(A[1] - B[j]);
    }

    for(int i=2;i<=N;i++)
    {
        int preMinCost = dp[(i-1)%2][1];
        for(int j=1;j<=N;j++)
        {
            preMinCost = min(preMinCost,dp[(i-1)%2][j]);
            dp[i%2][j] = preMinCost + abs(A[i]-B[j]);
        }
    }

    return *min_element(dp[N%2]+1,dp[N%2]+N+1);
}

int solveDown()
{
    //init
    sort(B+1,B+N+1);
    for(int j=1;j<=N;j++)
    {
        dp[1][j] = abs(A[1] - B[N+1-j]);
    }

    for(int i=2;i<=N;i++)
    {
        int preMinCost = dp[(i-1)%2][1];
        for(int j=1;j<=N;j++)
        {
            preMinCost = min(preMinCost,dp[(i-1)%2][j]);
            dp[i%2][j] = preMinCost + abs(A[i]-B[N+1-j]);
        }
    }

    return *min_element(dp[N%2]+1,dp[N%2]+N+1);
}
int main()
{
    cin>>N;
    for(int i=1;i<=N;i++)
    {
        cin >> A[i];
        B[i] = A[i];
    }
    cout<<min(solveDown(),solveUp())<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值