[PAT A1060 Are They Equal]

[PAT A1060 Are They Equal]

Description:

f a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

CODE:

#include <iostream>
#include <string>

using namespace std;

void process(string &str,int &exp,int n){
    int i=0;
    while((str[i]<'1' || str[i]>'9')&& i<str.size()){
        i++;
    }
    if(i==str.size()){
        str.clear();
        exp=0;
        while(n--){
            str+="0";
        }
        return;
    }
    int pos=str.find(".");
    if(pos!=string::npos){
        str.erase(pos,1);
    }else{
        pos=str.size();
    }
    
    if(pos<i)i--;
    str=str.substr(i,str.size()-i);

    while(str.size()<n)
       str=str+"0";
    str=str.substr(0,n);
    exp=pos-i;
}


void print_str(string str,int exp){
    printf("0.");
    for(string::iterator it=str.begin();it!=str.end();it++){
        printf("%c",*it);
    }
    printf("*10^%d",exp);
}

int main(){
    int n=0;
    string str1,str2;
    cin>>n>>str1>>str2;
    int exp1,exp2;
    process(str1,exp1,n);
    process(str2,exp2,n);

    if(str1==str2 && exp1==exp2){
        printf("YES ");
        print_str(str1,exp1);
    }
    else{
        printf("NO ");
        print_str(str1,exp1);
        printf(" ");
        print_str(str2,exp2);
    }
    return 0;
}

注意:

1)   在process中, 找到第一个有效数字,注意要加上i<str.size,否则对于0.000这样的数,i就飞走了,进而导致后面的substr运行错误

2)  在process中,  对于0,直接返回,不用继续处理

3)    在process中,对于类似0.0250的东西,先消除小数点,再截取,此时改变了i,需要将i--

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值