Family planning

Family planning

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7838    Accepted Submission(s): 2025


Problem Description
As far as we known,there are so many people in this world,expecially in china.But many people like LJ always insist on that more people more power.And he often says he will burn as much babies as he could.Unfortunatly,the president XiaoHu already found LJ's extreme mind,so he have to publish a policy to control the population from keep on growing.According the fact that there are much more men than women,and some parents are rich and well educated,so the president XiaoHu made a family planning policy:
According to every parents conditions to establish a number M which means that parents can born M children at most.But once borned a boy them can't born other babies any more.If anyone break the policy will punished for 10000RMB for the first time ,and twice for the next time.For example,if LJ only allowed to born 3 babies at most,but his first baby is a boy ,but he keep on borning another 3 babies, so he will be punished for 70000RMB(10000+20000+40000) totaly.
 

Input
The first line of the input contains an integer T(1 <= T <= 100) which means the number of test cases.In every case first input two integers M(0<=M<=30) and N(0<=N<=30),N represent the number of babies a couple borned,then in the follow line are N binary numbers,0 represent girl,and 1 represent boy.
 

Output
Foreach test case you should output the total money a couple have to pay for their babies.
 

Sample Input
  
  
2 2 5 0 0 1 1 1 2 2 0 0
 

Sample Output
  
  
70000 RMB 0 RMB
 
#include <stdio.h>
#include <math.h>
int main()
{
	int times,m,n,boy,a[30],flag,sum=0;
	//double sum=0;
	scanf("%d",×);//次数
	while(times--)
	{
		scanf("%d%d",&m,&n);
		flag=0;//标记在m之内是否出现过1
		boy=n;
		for (int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for (i=0;i<n;i++)
		{
			if (a[i]==1&&i<m)
			{
				flag=1;//说明出现了
                boy=i+1;//这个是第几个不是序号,序号是从0开始,这个是从1开始
				break;
			}
		}
		if (flag==0)
		{
			if (n>=m)//如果n>=m,则把boy设为m,
			{
				boy=m;//如果n<m说明你出生的孩子数目没有超过计划的就常规的讨论
			}
            
		}
		sum=pow(2,n-boy)-1;//从这里可以看出为什么把boy设为n的必要了吧!
		if (sum==0)
		{
			printf("0 RMB\n");
		}
		else
		{
			printf("%d0000 RMB\n",sum);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值