HDU 2013 Family planning



Family planning

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11928    Accepted Submission(s): 3128


Problem Description
As far as we known,there are so many people in this world,expecially in china.But many people like LJ always insist on that more people more power.And he often says he will burn as much babies as he could.Unfortunatly,the president XiaoHu already found LJ's extreme mind,so he have to publish a policy to control the population from keep on growing.According the fact that there are much more men than women,and some parents are rich and well educated,so the president XiaoHu made a family planning policy:
According to every parents conditions to establish a number M which means that parents can born M children at most.But once borned a boy them can't born other babies any more.If anyone break the policy will punished for 10000RMB for the first time ,and twice for the next time.For example,if LJ only allowed to born 3 babies at most,but his first baby is a boy ,but he keep on borning another 3 babies, so he will be punished for 70000RMB(10000+20000+40000) totaly.
 

Input
The first line of the input contains an integer T(1 <= T <= 100) which means the number of test cases.In every case first input two integers M(0<=M<=30) and N(0<=N<=30),N represent the number of babies a couple borned,then in the follow line are N binary numbers,0 represent girl,and 1 represent boy.
 

Output
Foreach test case you should output the total money a couple have to pay for their babies.
 

Sample Input
 
 
22 50 0 1 1 12 20 0
 
Sample Output
 
 
70000 RMB0 RMB
#include<stdio.h>
int main()
{
    int t,m,n,i,k,j,s,p,a[100];
    long long int sum,r;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            sum=0;r=5000;
            scanf("%d%d",&m,&n);
            for(i=1;i<=n;i++)
                scanf("%d",&a[i]);
                if(n==0) s=0;
            if(m==0) s=n;
            if(m!=0)
            {
                for(j=1;j<=n;j++)
                {
                    if(n>m)
                    {
                        for(k=1;k<=m;k++)
                        {
                            if(a[k]==1)
                            {
                                s=n-k;
                                break;
                            }
                            else
                            s=n-m;
                        }
                    }
                    if(n<=m)
                    {
                        if(a[j]==1&&j!=n)
                        {
                            s=n-j;
                            break;
                        }
                        if(a[j]==1&&j==n||a[j]==0)
                        s=0;
                    }
                }
            }
            for(p=1;p<=s;p++)
                {
                    r=r*2;
                    sum+=r;
                }
            printf("%lld RMB\n",sum);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值