Just a Numble(求小数的第N位数)

Just a Numble

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2410    Accepted Submission(s): 1160


Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
 

Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
 

Output
For each line of input, your program should print a numble on a line,according to the above rules
 

Sample Input
  
  
4 2 5 7 123 123
 

Sample Output
  
  
5 0 8
 

#include<stdio.h>
int main()
{
	int n,m,i,j,sum;
	int k;	while(scanf("%d%d",&n,&m)!=EOF)
	{
		sum=1;
		for(i=0;i<m;i++)
		{
			sum=sum*10;//这个题的意思是让每一位都X10,比如求得第一位
			k=sum/n;//k即为第一位小数
			sum=sum%n;//求得余数,还得让余数继续除以n也很好理解!
		}
		printf("%d\n",k%10);
	}
}

也很好理解的,不过最好还是借用一下画画来更加清晰地认识!


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值