Problem C: Chicken and rabbits

Problem C: Chicken and rabbits

Time Limit: 1 Sec   Memory Limit: 32 MB
Submit: 75   Solved: 21
[ Submit][ Status][ Web Board]

Description

Chicken and rabbits are in a same cage. As we all know, chicken has two legs but rabbit has four. Now
we know the number of legs in the cage is A, please tell me how many animals may in the cage at least
and at most.

Input

The first line of the input contains the number of test cases in the file. Each test case that follows
consists of one lines. each case contains only one integer numbers A specifying the total legs in the
cage .

Output

For each test case, print a line contains the answer

Sample Input

2
3
20

Sample Output

0 0
5 10

HINT

这一题,很简单,但是得看到一个错误!那就是数据2,当时我没看到,错了!

不过现在这个代码友好多了!

#include <stdio.h>
int main()
{
	int times,n,max,min;
	scanf("%d",×);
	while (times--)
	{
		scanf("%d",&n);
		if (n%2!=0)
		{
			printf("0 0\n");
		}
		else
		{
			max=n/2;
			if (n%4==0)
			{
				min=n/4;
			}
			else
			{
				min=n/4+1;
			}
			printf("%d %d\n",min,max);
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值