C hicken and rabbit s

时间限制: 1 Sec  内存限制: 32 MB

提交: 40   解决: 29
[ 提交][ 状态][ 讨论版]

题目描述

Chicken and rabbits are in a same cage. As we all know, chicken has two legs but rabbit has four. Now
we know the number of legs in the cage is A, please tell me how many animals may in the cage at least
and at most.

输入

The first line of the input contains the number of test cases in the file. Each test case that follows
consists of one lines. each case contains only one integer numbers A specifying the total legs in the
cage .

输出

For each test case, print a line contains the answer

样例输入

2
3
20

样例输出

0 0
5 10
 
 
 
 
#include<stdio.h> 
int main() 
{ 
     int n; 
    scanf("%d",&n); 
    while(n--) 
    { 
        long long m; 
        scanf("%lld",&m); 
        if(m%2==1) 
        { 
            printf("0 0\n"); 
            continue;  
        }    
        if(m%4==0) 
        printf("%lld ",m/4); 
        else
        printf("%lld ",m/4+1); 
        printf("%lld\n",m/2); 
    } 
    return 0; 
    } 
/************************************************************** 
    Problem: 1205  
    Language: C 
    Result: 正确 
    Time:0 ms 
    Memory:768 kb 
****************************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值