Wolf and Rabbit(欧几里得)

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5929    Accepted Submission(s): 2977


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
  
  
2 1 2 2 2
 

Sample Output
  
  
NO YES
 

Author
weigang Lee
 


这一题的题目让你狼每次走m个,走过k次能把0------------------n-1中所有的序号走完,问你有可能吗?


即m*k%n=0,1,2,3,4,5,6,7......n-1


假设m,n是互素的,则一定存在一个x 满足 m x mod  n 分别余 k = 1,2,3,4,、、、n-1,即 mx mod n = k 有解。其中x为狼转的圈数,k为洞的


编号。说明如果m,n互素,只要这只狼足够耐心,所有的洞都会让它找一遍。。。


#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int exGcd(int a,int b,int &x,int &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		return a;// 此时a是最开始(a,b)的最大公约数,那么  gcd(a,b)*1+ 0*0=gcd(a,b),肯定对的,在这里,我认为,y可以为任何值都对
	}

	int d=exGcd(b,a%b,y,x);
	y-=a/b*x;
	return d;//返回最大公约数
}
int main()
{
    int n,m,t,x,y;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        if(exGcd(n,m,x,y)==1)
        {
            cout<<"NO"<<endl;
        }
        else
        {
            cout<<"YES"<<endl;
        }
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值