A + B for you again(KMP)

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4940    Accepted Submission(s): 1248


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

Author
Wang Ye
 

Source
 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = 100005,MAXM = 100005;
char A[MAXN],B[MAXM];
int Next[MAXM];
void get_next(char *a,int len){
    int i=-1,j=0;
    Next[0]=-1;
    while(j<len){
        if(i == -1 || a[i] == a[j]){
            if(a[++i] == a[++j])Next[j]=Next[i];
            else Next[j]=i;
        }else i=Next[i];
    }
}

int KMP(char *a,char *b,int lena,int lenb){
    get_next(a,lena);
    int i=0,j=0;
    while(i<lena && j<lenb){
        if(i == -1 || a[i] == b[j])++i,++j;
        else i=Next[i];
    }
    if(i<lena || (i == lena && j == lenb))return i;//a不能是b中间部分的字串
    return 0;
}

int main()
{
    int len1,len2,p1,p2,i;
    while(cin>>A>>B)
    {
        //cout<<T<<" "<<P<<endl;
        len1=strlen(A);
        len2=strlen(B);
        p1=KMP(A,B,len1,len2);//B中找A,找到的最大长度
        p2=KMP(B,A,len2,len1);//A中找B,找到的最大长度
        /*
        比如:asdf sdfg
        在B中根本找不到A的子串(必须从头开始)
        而在A中却能找到B的子串最大长度为3
        所以输出 0 3
        cout<<p1<<" "<<p2<<endl;*/
        if(p1==p2)
        {
            if(strcmp(A,B)<0)
            {
                cout<<A;
                cout<<B+p2<<endl;
            }
            else
            {
                cout<<B;
                cout<<A+p1<<endl;
            }
        }
        else
        {
            if(p1>p2)//说明在B中找到了A的子串
            {
                cout<<B;
                cout<<A+p1<<endl;
            }
            else//在A中找到了B的子串
            {
                cout<<A;
                cout<<B+p2<<endl;
            }
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值