费马小定理

 

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6976    Accepted Submission(s): 4822


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
      
      
11 100 9999
 

Sample Output
      
      
22 no 43
#include <stdio.h>

void main()
{
	int k,flag;
	while(scanf("%d",&k)!=EOF)
	{
	     flag=0;
		 for(int i=1;i<=65;i++)//到65就能被65整除了
		 {
		    if(i*k%13==8&&i*k%5==2)//题目要满足的条件,(费马小定理)
			{	flag=i;//这是一种输出方法
			    break;
			}
		 }
		 if(flag)//一种输出方法
			 printf("%d\n",flag);
		 else
			 printf("no\n");
	
	}
	
}<p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="font-size: 32px; color: rgb(255, 0, 0);">这一题是一个好题,涉及到费马小定理!</span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="font-size: 32px; color: rgb(255, 0, 0);">什么是费马小定理呢?</span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="font-size: 32px;"><span style="color: rgb(255, 102, 102);"><span style="font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">费马小定理(Fermat Theory)是数论中的一个重要定理,其内容为: 假如p是</span><a target=_blank target="_blank" class="ed_inner_link" href="http://baike.sogou.com/lemma/ShowInnerLink.htm?lemmaId=67850&ss_c=ssc.citiao.link" style="color: rgb(202, 0, 0); text-decoration: none; font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">质数</a><span style="font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">,且Gcd(a,p)=1,那么 a(p-1) ≡1(mod p)。即:假如a是整数,p是质数,且a,p互质(即两者只有一个</span><a target=_blank target="_blank" class="ed_inner_link" href="http://baike.sogou.com/lemma/ShowInnerLink.htm?lemmaId=7531927&ss_c=ssc.citiao.link" style="color: rgb(202, 0, 0); text-decoration: none; font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">公约数</a><span style="font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">1),那么a的(p-1)</span><a target=_blank target="_blank" class="ed_inner_link" href="http://baike.sogou.com/lemma/ShowInnerLink.htm?lemmaId=73782511&ss_c=ssc.citiao.link" style="color: rgb(202, 0, 0); text-decoration: none; font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">次方</a><span style="font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">除以p的</span><a target=_blank target="_blank" class="ed_inner_link" href="http://baike.sogou.com/lemma/ShowInnerLink.htm?lemmaId=795886&ss_c=ssc.citiao.link" style="color: rgb(202, 0, 0); text-decoration: none; font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">余数</a><span style="font-family: Arial, Helvetica, sans-serif, SimSun; font-size: 14px; line-height: 28px; text-indent: 28px;">恒等于1。该定理是1636年皮埃尔·德·费马发现的。</span></span>
</span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="font-size: 32px; color: rgb(255, 0, 0);"><span style="font-family: Arial, Helvetica, sans-serif, SimSun; line-height: 28px; text-indent: 28px;">所以我们要做的就是把这一题与费马小定理联系起来!</span></span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="color: rgb(255, 0, 0);"><span style="font-family: Arial, Helvetica, sans-serif, SimSun; line-height: 28px; text-indent: 28px;"><span style="font-family: 'Times New Roman';"><span style="font-size: 24px;">f(x)=5*x^13+13*x^5+k*a*x转化成f(x)=(5*x^12+13*x^4+k*a)*x</span></span>
</span></span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="color: rgb(255, 0, 0);"><span style="font-family: Arial, Helvetica, sans-serif, SimSun; line-height: 28px; text-indent: 28px;"><span style="font-family: 'Times New Roman';"><span style="font-size: 24px;">1.当x=65的倍数时就行了;</span></span></span></span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="color: rgb(255, 0, 0);"><span style="font-family: Arial, Helvetica, sans-serif, SimSun; line-height: 28px; text-indent: 28px;"><span style="font-family: 'Times New Roman';"><span style="font-size: 24px;">2.当x=5的倍数时则需要(5*x^12+k*a)是13的倍数,由费马小定理可知,因为x是5的倍数所以(x^(13-1)%13==1),所以(5*x^12%13==5),所以只需要做到k*a%13==8即可!</span></span></span></span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="color: rgb(255, 0, 0);"><span style="font-family: Arial, Helvetica, sans-serif, SimSun; line-height: 28px; text-indent: 28px;"><span style="font-family: 'Times New Roman';"><span style="font-size: 24px;">3.同理可得当x=13的倍数时,只需要做到(13*x^4+k*a)是5的倍数由费马小定理可知,因为x是5的倍数所以(x^(5-1)%5==1),所以(13*x^(5-1)%5==3),所以只需要做到k*a%5==2即可</span></span></span></span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px; font-family: Arial; font-size: 14px; line-height: 26px;"><span style="color: rgb(255, 0, 0);"><span style="font-family: Arial, Helvetica, sans-serif, SimSun; line-height: 28px; text-indent: 28px;"><span style="font-family: 'Times New Roman';"><span style="font-size: 24px;">4.当x不是上面的特殊数时,则需要f(x)=(5*x^12+13*x^4+k*a)*x被65整除,也就是需要同时满足上面那两个条件!------------------------2015/3/4 (copy jb's csdn)</span></span></span></span></p>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值