20150728多校第三场1004 - Painter

Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.


Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50

The number of column of the rectangle is also less than 50.


Output
Output an integer as described in the problem description.


Output
Output an integer as described in the problem description.


Sample Input
2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR


Sample Output
3

6


这道题的题意是:一个画家只能以“ \ "的方向涂红色,以” / “的方向涂蓝色(斜率只能为正负1),如果一个方框既涂了红色又涂了蓝色则会显示出绿色。先开始画布是空白的,给你一个矩阵表示最终画布上的颜色,R表示红色,B表示蓝色,G表示绿色,” . “表示空白。输出最少需要画的步数,画一步必须是连续的。

注意:给你的是n行字符串,但字符串的长度不一定是n。

思路:将给出的最终画布还原成空白的,统计最少需要几步。


<span style="color:#660000;">//
//  main.cpp
//  balabala
//
//  Created by zyh on 15/7/24.
//  Copyright (c) 2015年 zyh. All rights reserved.
//

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <string>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        char s[55][55];
        for(int i=0;i<n;i++)
        {
            scanf("%s",s[i]);
        }
        int m;
        m=strlen(s[0]);
        int cnt=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)            //</span><span style="color: rgb(102, 0, 0); font-family: Arial, Helvetica, sans-serif;">从第一个位置开始扫</span><span style="color:#660000;">
            {
                if(s[i][j]=='R'||s[i][j]=='G')      //如果扫到R则还原成”.“,如果扫到G则还原成B。
                {
                    int x=i,y=j;
                    while(x<n&&y<m)              //从找到的这一位置开始向斜右下方枚举,直到枚举到不是R或G的境况。
                    {
                        if(s[x][y]=='R')
                        {
                            s[x][y]='.';
                            x++;
                            y++;
                        }
                        else if(s[x][y]=='G')
                        {
                            s[x][y]='B';
                            x++;
                            y++;
                        }
                        else break;
                    }
                    cnt++;       //步数+1
                }
            }
        }</span>
<span style="color:#660000;">        //此时只剩下”.“和B了。</span>
<span style="color:#660000;">        for(int i=0;i<n;i++)           
        {
            for(int j=0;j<m;j++)
            {
                if(s[i][j]=='B')             //同理扫B
                {
                    int x=i,y=j;
                    while(x<n&&y>=0)
                    {
                        if(s[x][y]=='B')
                        {
                            s[x][y]='.';
                            x++;
                            y--;
                        }
                        else break;
                    }
                    cnt++;
                }
            }
        }
        printf("%d\n",cnt);        //输出最少步数。
    }
    return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值