20150728多校第三场1011 - work

Problem Description
It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.


Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n


Output
For each test case, output the answer as described above.


Sample Input
7 2
1 2
1 3
2 4
2 5
3 6
3 7


Sample Output

2


题意:一共n个人,用n-1行输入a b表示a能直接领导b,求出几个人能领导k个人(包括直接领导和间接领导两种)

大致思路:记录每个人能直接领导的人,要统计某一个人能领导的人数,就用一个队列。比如样例中,要统计1能领导多少人,先把1放入队列,cnt=0,在把1直接领导的人(即2,3)放入队列,cnt=2,把1踢出队列,再把2所能直接领导的人(即4,5)放入队列,如此反复直到队列为空,则cnt=6;


//
//  main.cpp
//  balabala
//
//  Created by zyh on 15/7/24.
//  Copyright (c) 2015年 zyh. All rights reserved.
//

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <string>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;

struct node
{
    int c;       //存第i个人能直接领导的人的个数
    vector<int> v;        //存第i个人能直接领导哪些人
}re[1005];         //re[i]表示第i个人。
queue <int> q;

int finds()               //统计第i个人能领导的人数。
{
    int cnt=0;
    while(!q.empty())
    {
        int b=q.front();
        q.pop();
        for(int i=0;i<re[b].c;i++)
        {
            q.push(re[b].v[i]);
            cnt++;
        }
    }
    return cnt;
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            re[i].c=0;
            re[i].v.clear();              //注意清空数组。第一次WA在这了。
        }
        for(int i=0;i<n-1;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            re[x].v.push_back(y);
            re[x].c++;
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            int cnt;
            q.push(i);
            cnt=finds();
            if(cnt==m)      //如果第i个人能领导的人数符合要求,ans+1。
            {
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值