HDU1520 Anniversary party(树形DP)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8869 Accepted Submission(s): 3824


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.


Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0


Output
Output should contain the maximal sum of guests' ratings.


Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0


Sample Output

5


题意:N个人,给出每个人的活跃度a[i]。然后给出若干行关系L K,表示K是L的上司,以0 0结束。一个人和他的直系上司不能同时参加聚会,问怎样安排聚会才能使活跃度最高。



思路:令dp[i][j]为第i个人是否参加聚会,j=0或1。建一棵树,上司是父节点。没有在L中出现的为根,从根往下dfs,找到叶子节点,将叶子节点初始化为dp[i][1]=a[i],dp[i][0]=0;

对于非叶子节点,设其子节点为v,dp[i][1]+=sum(dp[v][0])+a[i],dp[i][0]+=sum(max(dp[v][0],dp[v][1])。


#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <string>
using namespace std;

int n;
int a[6005];
vector<int> v[6005];
int vis[6005];
int dp[6005][2];

void dfs(int s)
{
    if(v[s].size()==0)
    {
        dp[s][0]=0;
        dp[s][1]=a[s];
        return;
    }
    for(int i=0;i<v[s].size();i++)
    {
        dfs(v[s][i]);
        dp[s][0]+=max(dp[v[s][i]][0],dp[v[s][i]][1]);
        dp[s][1]+=dp[v[s][i]][0];
    }
    dp[s][1]+=a[s];
    return;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0;i<=n;i++)
            v[i].clear();
        int l,k;
        memset(vis,0,sizeof(vis));
        memset(dp,0,sizeof(dp));
        while(1)
        {
            scanf("%d%d",&l,&k);
            if(l==0&&k==0) break;
            v[k].push_back(l);
            vis[l]=1;
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(vis[i]==0)
            {
                dfs(i);
                ans+=max(dp[i][1],dp[i][0]);
            }
        }
        printf("%d\n",ans);
    }
   


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值