HDU 1505 City Game(DP)


Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.


Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.


Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.


Sample Input
2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R


Sample Output
45

0


题意:一个N*M的矩阵,每格是R或F,求最大的子矩阵面积满足他的所有格子都是F。


思路:首先对于每个格子,预处理出他向上最多能包含多少F,计入数组dp[i][j]。

R F F F F F                           0 1 1 1 1 1

F F F F F F                           1 2 2 2 2 2
R R R F F F           --->         0 0 0 3 3 3
F F F F F F                           1 1 1 4 4 4
F F F F F F                           2 2 2 5 5 5

对于每一行i,l[j]表示从(i,j)向左到(i,l[j]),dp[i][x]都大于等于dp[i][j]。r[j]表示从(i,j)向右到(i,r[j]),dp[i][x]都大于等于dp[i][j]。这样,对于(i,j)就可以构成一个(r[j]-l[j]+1)*dp[i][j]的矩阵。

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <string>
using namespace std;

char a[1005][1005];
int n,m;
int dp[1005][1005];
int l[1005],r[1005];


int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        getchar();
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin>>a[i][j];
            }
        }
        for(int i=1;i<=m;i++)
            dp[0][i]=0;
        for(int j=1;j<=m;j++)
        {
            for(int i=1;i<=n;i++)
            {
                if(a[i][j]=='R') dp[i][j]=0;
                else dp[i][j]=dp[i-1][j]+1;
            }
        }
        int imax=-1;
        for(int i=1;i<=n;i++)
        {
            l[1]=1;
            r[m]=m;
            for(int j=2;j<=m;j++)
            {
                if(dp[i][j]==0) continue;
                int t=j;
                while(t>1&&dp[i][j]<=dp[i][t-1]) 

                {
                    t=l[t-1];
                }
                l[j]=t;
            }
            for(int j=m-1;j>=1;j--)
            {
                if(dp[i][j]==0) continue;
                int t=j;
                while(t<m&&dp[i][j]<=dp[i][t+1])    //这样求r[j]的复杂度应该是log的
                {
                    t=r[t+1];
                }
                r[j]=t;
            }
            for(int j=1;j<=m;j++)
            {
                imax=max(imax,(r[j]-l[j]+1)*dp[i][j]*3);
            }
        }
        cout<<imax<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值