HDU 5900 QSC and Master(区间DP)

Problem Description
Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300
1<=Ai.key<=1,000,000,000
0<Ai.value<=1,000,000,000)


Input
First line contains a integer T,means there are T(1≤T≤10) test case。

Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.


Output
For each test case,output the max score you could get in a line.


Sample Input
3
3
1 2 3
1 1 1
3
1 2 4
1 1 1
4
1 3 4 3
1 1 1 1



Sample Output
0
2

0


题意:N个数,每个数有一个K值和一个val值,如果两个数相邻且K值不互质,就是能将这两个数取出,他们两边的数字变为相邻。问取出的数val值和最大是多少。

思路:先预处理出一个区间内的数是否全部能取出。dp[i][j]表示[i,j]区间能取的最大值。sum[i]表示[1,i]的val值前缀和。对于一个区间,如果全能取出,dp[i][j]等于sum[j]-sum[i-1]。如果不能全部取出,则枚举l(i<=l<j),dp[i][j]=max(dp[i][j],dp[i][l]+dp[l+1][j]).


#include <cstring>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>

using namespace std;

typedef long long LL;

LL k[305];
LL val[305];
LL sum[305];
bool d[305][305];
LL dp[305][305];

LL gcd(LL a, LL b)
{
  if (b == 0)
    return a;
  return gcd(b, a%b);
}

int main()
{
  int t;
  cin>>t;
  while(t--)
  {
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
      scanf("%lld",&k[i]);
    }
    sum[0] = 0;
    for(int i=1;i<=n;i++)
    {
      scanf("%lld", &val[i]);
      sum[i] = sum[i - 1] + val[i];
    }
    memset(d, 0, sizeof(d));
    for (int len = 2; len <= n; ++len) {
      for (int i = 1; i + len - 1 <= n; ++i) {
        int j = i + len - 1;
        if (len == 2) {
          d[i][j] = gcd(k[i], k[j]) != 1;
          continue;
        }
        d[i][j] = d[i + 1][j - 1] && (gcd(k[i], k[j]) != 1LL);
        for (int w = i; w < j; ++w) {
          d[i][j] |= d[i][w] && d[w + 1][j];
        }
      }
    }
    memset(dp, 0, sizeof(dp));
    for(int i=n-1;i>0;i--)
    {
      for(int j=i+1;j<=n;j++)
      {
        if(d[i][j])
        {
          dp[i][j]=sum[j]-sum[i-1];
          continue;
        }
        for(int l=i;l<j;l++)
        {
          dp[i][j]=max(dp[i][j],dp[i][l]+dp[l+1][j]);
        }
      }
    }
    printf("%lld\n",dp[1][n]);
  }
  return 0;
}
/*
 100
 3
 1 2 3
 1 1 1
 3
 1 2 4
 1 1 1
 4
 1 3 4 3
 1 1 1 1
 4
 2 3 9 4
 1 1 1 1
 */


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值