CUDA driver version is insufficient for CUDA runtime version

安装好CUDA8.0后运行deviceQuery报错

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

查了很多办法都没有解决,dpkg -l | grep cuda 发现

存在libcuda1-304 ,另外还有libcuda1-375 版本为 375.66,高于cuda-drivers的版本375.51,于是用sudo apt-get --purge remove libcuda1-375卸载,并用dpkg -i重新安装

cuda* cuda-8-0* cuda-demo-suite-8-0* cuda-drivers* cuda-runtime-8-0*
  libcuda1-375*

等,问题解决。

展开阅读全文

没有更多推荐了,返回首页