Sacrament of the sum
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 2174 | Accepted: 979 |
Description
— The Brother of mine, the Head of Monastic Order wants to know tomorrow about the results long-term researches. He wants to see neither more nor less than the Summering Machine! Even moreover, he wants our Machine — only a machine — to demonstrate its comprehension of the Sacrament of the Sum as deeply as it is possible. He wants our Machine to find two numbers that give the sum equal to the Sacred Number 10 000.
— Tsh-sh-sh! This is madness that borders on blasphemy! How can the Machine calculate the Sacred Number? Twenty seven years we work on it, but we've could teach it to tell if the sum of two introduced numbers greater or lower than 10 000. Can an ordinary mortal find two numbers that there sum will be equal to 10 000?
— But we'll have to do it with the help of our Machine, even if it is not capable. Otherwise we'll have... let's say, big problems, if it is possible to call boiling oil like this. However, I have an idea. Do you remember, last week we've entered two numbers -7 and 13 into the Machine, and it answered that their sum is lower than 10 000. I don't know how to check this, but nothing's left for us than to believe to the fruit of our work. Let's enter now a greater number than -7 and start up the Machine again. We'll do like this again and again until we find a number that being added to 13 will give us 10 000. The only thing we are to do is to prepare an ascending list of numbers.
— I don't believe in this... Let's start with the sum that is obviously greater than the Sacred Number and we'll decrease one of the summand. So we have more chances to avoid boilin... big problems.
Haven't come to an agreement, the Brothers went away to their cells. By next day everyone of them has prepared a list of numbers that, to his opinion, could save them... Can both of the lists save them together?
Your program should decide, if it is possible to choose from two lists of integers such two numbers that their sum would be equal to 10 000.
— Tsh-sh-sh! This is madness that borders on blasphemy! How can the Machine calculate the Sacred Number? Twenty seven years we work on it, but we've could teach it to tell if the sum of two introduced numbers greater or lower than 10 000. Can an ordinary mortal find two numbers that there sum will be equal to 10 000?
— But we'll have to do it with the help of our Machine, even if it is not capable. Otherwise we'll have... let's say, big problems, if it is possible to call boiling oil like this. However, I have an idea. Do you remember, last week we've entered two numbers -7 and 13 into the Machine, and it answered that their sum is lower than 10 000. I don't know how to check this, but nothing's left for us than to believe to the fruit of our work. Let's enter now a greater number than -7 and start up the Machine again. We'll do like this again and again until we find a number that being added to 13 will give us 10 000. The only thing we are to do is to prepare an ascending list of numbers.
— I don't believe in this... Let's start with the sum that is obviously greater than the Sacred Number and we'll decrease one of the summand. So we have more chances to avoid boilin... big problems.
Haven't come to an agreement, the Brothers went away to their cells. By next day everyone of them has prepared a list of numbers that, to his opinion, could save them... Can both of the lists save them together?
Your program should decide, if it is possible to choose from two lists of integers such two numbers that their sum would be equal to 10 000.
Input
You are given both of these lists one by one. Format of each of these lists is as follows: in the first line of the list the quantity of numbers Ni of the i-th list is written. Further there is an i-th list of numbers each number in its line (Ni lines).The following conditions are satisfied: 1 <= Ni <= 50 000, each element of the lists lays in the range from -32768 to 32767. The first list is ascending and the second one is descending.
Output
You should write "YES" to the standard output if it is possible to choose from the two lists of integers such two numbers that their sum would be equal to 10 000. Otherwise you should write "NO".
Sample Input
4 -175 19 19 10424 3 8951 -424 -788
Sample Output
YES
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source
题目本身不难但是卡了好久。因为一个break。
说明以后在有输入输出的循环里加break要格外注意。
用了二分搜索法,不过这个题目还可以hash。之后补充hash。
#include <iostream>
#include<stdio.h>
using namespace std;
const int M=50005;
int s1[M];
int bs(int n,int key)
{
int lo=0,hi=n-1;
int mid;
while(hi>=lo)
{
mid=(hi+lo)/2;
if(s1[mid]==key)
return 1;
else if(s1[mid]<key)
lo=mid+1;
else
hi=mid-1;
}
return 0;
}
int main()
{
int n1,n2;
int s2;
int f;
while(scanf("%d",&n1)!=EOF)
{
f=0;
for(int i=0;i<n1;i++)
scanf("%d",&s1[i]);
scanf("%d",&n2);
for(int i=0;i<n2;i++)
{
scanf("%d",&s2);
if(!f&&bs(n1,10000-s2))
{
f=1; //break; 就是这个break会导致前一个输入提前结束,后续数据读入下个循环。切记!
}
}
if(f)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
hash如下
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int M=50005;
int ha[M*2];
int main()
{
int n1,n2;
int nu;
int s2;
int f;
while(scanf("%d",&n1)!=EOF)
{
f=0;
memset(ha,0,sizeof(ha));
for(int i=0;i<n1;i++)
{
scanf("%d",&nu);
ha[nu+M]=1;
}
scanf("%d",&n2);
for(int i=0;i<n2;i++)
{
scanf("%d",&s2);
if(ha[10000-s2+M])
f=1;
}
if(f)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
还有就是感觉上可以用map但是实际上会超时,估计有数据让map退化了?