POJ_2709_Painter

13 篇文章 0 订阅
3 篇文章 0 订阅

Painter
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3725 Accepted: 2252

Description

The local toy store sells small fingerpainting kits with between three and twelve 50ml bottles of paint, each a different color. The paints are bright and fun to work with, and have the useful property that if you mix X ml each of any three different colors, you get X ml of gray. (The paints are thick and "airy", almost like cake frosting, and when you mix them together the volume doesn't increase, the paint just gets more dense.) None of the individual colors are gray; the only way to get gray is by mixing exactly three distinct colors, but it doesn't matter which three. Your friend Emily is an elementary school teacher and every Friday she does a fingerpainting project with her class. Given the number of different colors needed, the amount of each color, and the amount of gray, your job is to calculate the number of kits needed for her class.

Input

The input consists of one or more test cases, followed by a line containing only zero that signals the end of the input. Each test case consists of a single line of five or more integers, which are separated by a space. The first integer N is the number of different colors (3 <= N <= 12). Following that are N different nonnegative integers, each at most 1,000, that specify the amount of each color needed. Last is a nonnegative integer G <= 1,000 that specifies the amount of gray needed. All quantities are in ml. 

Output

For each test case, output the smallest number of fingerpainting kits sufficient to provide the required amounts of all the colors and gray. Note that all grays are considered equal, so in order to find the minimum number of kits for a test case you may need to make grays using different combinations of three distinct colors.

Sample Input

3 40 95 21 0
7 25 60 400 250 0 60 0 500
4 90 95 75 95 10
4 90 95 75 95 11
5 0 0 0 0 0 333
0

Sample Output

2
8
2
3
4

Source



贪心的一个问题,优先用多出的颜料多的,来配置灰色的颜料

这里需要注意的是配灰颜料的时候,要1ml 1ml的配置

因为时刻保证使用的是最多的才能保证最后的解最小,

其实5 0 0 0 0 0 333那组数据就很说明问题了,如果只是单纯的取最多的来配

那么会使后两组完全剩下来,这样是不对的。

另外这个问题应该用优先队列来进行更好些,我用了每次排序的办法,比较低效竟然也过了……

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

const int M=15;
int p[M];

bool cmp(int a,int b)
{
    return a>b;
}

int main()
{
    int n;
    int lea;
    int grey;
    int so;
    while(1)
    {
        lea=0;
        scanf("%d",&n);
        if(n==0)
            break;
        for(int i=0;i<n;i++)
        {
             scanf("%d",&p[i]);
             lea=max(lea,p[i]);
        }
        scanf("%d",&grey);
        if(lea%50==0)
            so=lea/50;
        else
            so=lea/50+1;
        for(int i=0;i<n;i++)
            p[i]=50*so-p[i];
        while(grey>0)
        {
            sort(p,p+n,cmp);
            if(p[2]==0)
            {
                so++;
                for(int i=0;i<n;i++)
                    p[i]+=50;
            }
            p[0]--;p[1]--;p[2]--;grey--;
        }
        printf("%d\n",so);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值